aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorJan Hoffmann <jan@3e8.eu>2021-02-04 20:41:50 +0100
committerEtienne Champetier <champetier.etienne@gmail.com>2021-02-26 17:31:24 -0500
commit4bc7ba7fe82563dd64db57317c52824039ab8209 (patch)
tree54ba5c3b871a4ff985166cd723c81dea9bcc82ec /libs
parentd7a76b634ad96c90c646369e8dfa10c7ea3e0354 (diff)
sqlite3: add option for batch-atomic write support
This allows to build SQLite with support for the batch-atomic write optimization. It makes use of atomic write support provided by the underlying file system. Currently, this is only supported on F2FS. It it does not work with overlayfs. Signed-off-by: Jan Hoffmann <jan@3e8.eu>
Diffstat (limited to 'libs')
-rw-r--r--libs/sqlite3/Config-lib.in6
-rw-r--r--libs/sqlite3/Makefile6
2 files changed, 10 insertions, 2 deletions
diff --git a/libs/sqlite3/Config-lib.in b/libs/sqlite3/Config-lib.in
index 6e7ea18dc..bcf024aa6 100644
--- a/libs/sqlite3/Config-lib.in
+++ b/libs/sqlite3/Config-lib.in
@@ -1,6 +1,12 @@
menu "Configuration"
depends on PACKAGE_libsqlite3
+config SQLITE3_BATCH_ATOMIC_WRITE
+ bool "Batch-atomic write support"
+ default n
+ help
+ Enable batch-atomic write optimization (supported only on F2FS).
+
config SQLITE3_DYNAMIC_EXTENSIONS
bool "Dynamic extensions"
default y
diff --git a/libs/sqlite3/Makefile b/libs/sqlite3/Makefile
index c55ec658d..274101a5f 100644
--- a/libs/sqlite3/Makefile
+++ b/libs/sqlite3/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=sqlite
PKG_VERSION:=3330000
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-autoconf-$(PKG_VERSION).tar.gz
PKG_HASH:=106a2c48c7f75a298a7557bcc0d5f4f454e5b43811cc738b7ca294d6956bbb15
@@ -31,6 +31,7 @@ PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
PKG_CONFIG_DEPENDS := \
+ CONFIG_SQLITE3_BATCH_ATOMIC_WRITE \
CONFIG_SQLITE3_DYNAMIC_EXTENSIONS \
CONFIG_SQLITE3_FTS3 \
CONFIG_SQLITE3_FTS4 \
@@ -99,7 +100,8 @@ endef
TARGET_CFLAGS += \
-DHAVE_ISNAN \
-DHAVE_MALLOC_USABLE_SIZE \
- -DSQLITE_ENABLE_UNLOCK_NOTIFY
+ -DSQLITE_ENABLE_UNLOCK_NOTIFY \
+ $(if $(CONFIG_SQLITE3_BATCH_ATOMIC_WRITE),-DSQLITE_ENABLE_BATCH_ATOMIC_WRITE)
CONFIGURE_ARGS += \
--disable-debug \