aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-11-27 02:36:19 -0800
committerGitHub <noreply@github.com>2020-11-27 02:36:19 -0800
commit4b4ac939cc7ab101ebd6a5fba579546eb7ee65de (patch)
tree9892c04534df75473a924e10b97d10484e0f4217 /libs
parent165238242948701982f1a9167d5c86e9cc9fa1e9 (diff)
parent99b347905e0a691381dccc170a45329d588757cf (diff)
Merge pull request #14036 from neheb/libroxml
libroxml: import from base
Diffstat (limited to 'libs')
-rw-r--r--libs/libroxml/Makefile48
-rw-r--r--libs/libroxml/patches/010-gcc10.patch11
2 files changed, 59 insertions, 0 deletions
diff --git a/libs/libroxml/Makefile b/libs/libroxml/Makefile
new file mode 100644
index 000000000..0fb1e3e71
--- /dev/null
+++ b/libs/libroxml/Makefile
@@ -0,0 +1,48 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libroxml
+PKG_VERSION:=3.0.2
+PKG_RELEASE:=2
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://download.libroxml.net/pool/v3.x
+PKG_HASH:=ed6d68d1bceabf98e5e76907411e2e4d93b2dbd48479ab41dede851f59dad6a3
+
+PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
+PKG_LICENSE:=LGPL-2.1-or-later
+PKG_LICENSE_FILES:=License.txt
+
+CMAKE_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Package/libroxml
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=Minimum, easy-to-use, C implementation for xml file parsing
+ URL:=http://www.libroxml.net/
+ ABI_VERSION:=2
+endef
+
+CMAKE_OPTIONS += \
+ -DBUILD_TESTING=OFF \
+ -DCONFIG_XML_FILE=OFF \
+ -DCONFIG_XML_EDIT=OFF \
+ -DCONFIG_XML_COMMIT=OFF \
+ -DCONFIG_XML_XPATH=OFF
+
+define Package/libroxml/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libroxml.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libroxml))
diff --git a/libs/libroxml/patches/010-gcc10.patch b/libs/libroxml/patches/010-gcc10.patch
new file mode 100644
index 000000000..3c4fee653
--- /dev/null
+++ b/libs/libroxml/patches/010-gcc10.patch
@@ -0,0 +1,11 @@
+--- a/src/roxml_mem.h
++++ b/src/roxml_mem.h
+@@ -14,7 +14,7 @@
+
+ #include "roxml_internal.h"
+
+-memory_cell_t head_cell;
++extern memory_cell_t head_cell;
+
+ /** \brief alloc memory function
+ *