aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-03-06 14:00:32 -0800
committerGitHub <noreply@github.com>2021-03-06 14:00:32 -0800
commit45dcec32ce9458bb3a5116ef925a92fc3256e2d1 (patch)
tree9a3b7318f1482f77947763f74913adb1afaecaf0 /libs
parentf54cd876c9ebc02c8dd25a06bfb9576d0787c261 (diff)
parent39bc254663c6a5d54ff959366aba28f6ab9d7c4c (diff)
Merge pull request #14873 from neheb/cxx
treewide: remove uClibc++ support
Diffstat (limited to 'libs')
-rw-r--r--libs/db47/Makefile5
-rw-r--r--libs/gpgme/Makefile2
-rw-r--r--libs/ibrcommon/Makefile5
-rw-r--r--libs/ibrdtn/Makefile3
-rw-r--r--libs/ibrdtn/patches/010-Add-operator-to-Bundle-block_elem.patch23
-rw-r--r--libs/ibrdtn/patches/020-Use-const-iterator-in-const-function-of-MemoryBundle.patch20
-rw-r--r--libs/ibrdtn/patches/030-Use-std-streamoff-instead-of-std-streampos.patch37
-rw-r--r--libs/ibrdtn/patches/040-Add-operator-to-BundleID-and-MetaBundle.patch49
-rw-r--r--libs/libndpi/Makefile5
-rw-r--r--libs/libplist/Makefile27
-rw-r--r--libs/libv4l/Makefile5
-rw-r--r--libs/tiff/Makefile21
-rw-r--r--libs/vips/Makefile5
13 files changed, 15 insertions, 192 deletions
diff --git a/libs/db47/Makefile b/libs/db47/Makefile
index f0367387f..adf3dcf36 100644
--- a/libs/db47/Makefile
+++ b/libs/db47/Makefile
@@ -6,13 +6,12 @@
#
include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/uclibc++.mk
BASE_VERSION:=4.7.25
PKG_NAME:=db47
PKG_VERSION:=$(BASE_VERSION).4.NC
-PKG_RELEASE:=6
+PKG_RELEASE:=7
PKG_BUILD_DIR:=$(BUILD_DIR)/db-$(BASE_VERSION).NC
PKG_SOURCE:=db-$(BASE_VERSION).NC.tar.gz
@@ -45,7 +44,7 @@ endef
define Package/libdb47xx
SECTION:=libs
CATEGORY:=Libraries
- DEPENDS:=+libdb47 $(CXX_DEPENDS)
+ DEPENDS:=+libdb47 +libstdcpp
TITLE:=Berkeley DB library (4.7) for C++
URL:=http://www.oracle.com/us/products/database/berkeley-db
PROVIDES:=libdb47xx-full
diff --git a/libs/gpgme/Makefile b/libs/gpgme/Makefile
index ce3ae484d..74209fe39 100644
--- a/libs/gpgme/Makefile
+++ b/libs/gpgme/Makefile
@@ -31,7 +31,7 @@ define Package/libgpgmepp
CATEGORY:=Libraries
TITLE:=GnuPG Made Easy (GPGME) library (C++)
URL:=https://gnupg.org/software/gpgme/index.html
- DEPENDS:=+libgpgme +libstdcpp $(CXX_DEPENDS)
+ DEPENDS:=+libgpgme +libstdcpp
endef
define Package/libgpgme/description
diff --git a/libs/ibrcommon/Makefile b/libs/ibrcommon/Makefile
index dfa2e5910..43e26252d 100644
--- a/libs/ibrcommon/Makefile
+++ b/libs/ibrcommon/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ibrcommon
PKG_VERSION:=1.0.1
-PKG_RELEASE:=7
+PKG_RELEASE:=8
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.ibr.cs.tu-bs.de/projects/ibr-dtn/releases
@@ -20,13 +20,12 @@ PKG_LICENSE:=Apache-2.0
PKG_INSTALL:=1
PKG_FIXUP:=libtool
-include $(INCLUDE_DIR)/uclibc++.mk
include $(INCLUDE_DIR)/package.mk
define Package/ibrcommon
SECTION:=libs
CATEGORY:=Libraries
- DEPENDS:=$(CXX_DEPENDS) +librt +libnl +libopenssl
+ DEPENDS:=+libstdcpp +librt +libnl +libopenssl
TITLE:=IBR Common C++ Library
endef
diff --git a/libs/ibrdtn/Makefile b/libs/ibrdtn/Makefile
index c4aceba12..d85b2573a 100644
--- a/libs/ibrdtn/Makefile
+++ b/libs/ibrdtn/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ibrdtn
PKG_VERSION:=1.0.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.ibr.cs.tu-bs.de/projects/ibr-dtn/releases
@@ -20,7 +20,6 @@ PKG_LICENSE:=Apache-2.0
PKG_INSTALL:=1
PKG_FIXUP:=libtool
-include $(INCLUDE_DIR)/uclibc++.mk
include $(INCLUDE_DIR)/package.mk
define Package/ibrdtn
diff --git a/libs/ibrdtn/patches/010-Add-operator-to-Bundle-block_elem.patch b/libs/ibrdtn/patches/010-Add-operator-to-Bundle-block_elem.patch
deleted file mode 100644
index 1fcec0b97..000000000
--- a/libs/ibrdtn/patches/010-Add-operator-to-Bundle-block_elem.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 199c86591edc7e82b92903efecadc4f69ea63370 Mon Sep 17 00:00:00 2001
-From: Johannes Morgenroth <jm@m-network.de>
-Date: Tue, 1 Jan 2019 11:25:50 +0100
-Subject: [PATCH] Add operator!=() to Bundle::block_elem
-
-Alternative implementations of libstdcpp as uclibc++ use it in
-the algorithm implemenetations.
----
- ibrdtn/data/Bundle.h | 3 +++
- 1 file changed, 3 insertions(+)
-
---- a/ibrdtn/data/Bundle.h
-+++ b/ibrdtn/data/Bundle.h
-@@ -69,6 +69,9 @@ namespace dtn
- bool operator==(const dtn::data::block_t &type) const {
- return (**this) == type;
- }
-+ bool operator!=(const dtn::data::block_t &type) const {
-+ return !((**this) == type);
-+ }
- };
-
- typedef std::list<block_elem> block_list;
diff --git a/libs/ibrdtn/patches/020-Use-const-iterator-in-const-function-of-MemoryBundle.patch b/libs/ibrdtn/patches/020-Use-const-iterator-in-const-function-of-MemoryBundle.patch
deleted file mode 100644
index d585f3b75..000000000
--- a/libs/ibrdtn/patches/020-Use-const-iterator-in-const-function-of-MemoryBundle.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-From 6945698778caf7cdaace9ce8dae82162dbe2ee9f Mon Sep 17 00:00:00 2001
-From: Johannes Morgenroth <jm@m-network.de>
-Date: Thu, 3 Jan 2019 07:26:51 +0100
-Subject: [PATCH] Use const iterator in const function of MemoryBundleSet
-
----
- ibrdtn/data/MemoryBundleSet.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/ibrdtn/data/MemoryBundleSet.cpp
-+++ b/ibrdtn/data/MemoryBundleSet.cpp
-@@ -134,7 +134,7 @@ namespace dtn
- // the bundles set. This happen if the MemoryBundleSet gets deserialized.
- if (!_consistent) return true;
-
-- bundle_set::iterator iter = _bundles.find(dtn::data::MetaBundle::create(bundle));
-+ bundle_set::const_iterator iter = _bundles.find(dtn::data::MetaBundle::create(bundle));
- return (iter != _bundles.end());
- }
-
diff --git a/libs/ibrdtn/patches/030-Use-std-streamoff-instead-of-std-streampos.patch b/libs/ibrdtn/patches/030-Use-std-streamoff-instead-of-std-streampos.patch
deleted file mode 100644
index 8c9ac77fd..000000000
--- a/libs/ibrdtn/patches/030-Use-std-streamoff-instead-of-std-streampos.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 1395d849d73147319ee422d2ce34de0bcb90e6f8 Mon Sep 17 00:00:00 2001
-From: Johannes Morgenroth <jm@m-network.de>
-Date: Thu, 3 Jan 2019 07:34:14 +0100
-Subject: [PATCH] Use std::streamoff instead of std::streampos
-
----
- ibrdtn/data/BundleMerger.cpp | 2 +-
- ibrdtn/data/Dictionary.cpp | 4 ++--
- 2 files changed, 3 insertions(+), 3 deletions(-)
-
---- a/ibrdtn/data/BundleMerger.cpp
-+++ b/ibrdtn/data/BundleMerger.cpp
-@@ -119,7 +119,7 @@ namespace dtn
- }
-
- ibrcommon::BLOB::iostream stream = c._blob.iostream();
-- (*stream).seekp(obj.fragmentoffset.get<std::streampos>());
-+ (*stream).seekp(obj.fragmentoffset.get<std::streamoff>());
-
- const dtn::data::PayloadBlock &p = obj.find<dtn::data::PayloadBlock>();
- const Length plength = p.getLength();
---- a/ibrdtn/data/Dictionary.cpp
-+++ b/ibrdtn/data/Dictionary.cpp
-@@ -154,11 +154,11 @@ namespace dtn
- {
- char buffer[1024];
-
-- _bytestream.seekg(scheme.get<std::streampos>());
-+ _bytestream.seekg(scheme.get<std::streamoff>());
- _bytestream.get(buffer, 1024, '\0');
- std::string scheme_str(buffer);
-
-- _bytestream.seekg(ssp.get<std::streampos>());
-+ _bytestream.seekg(ssp.get<std::streamoff>());
- _bytestream.get(buffer, 1024, '\0');
- std::string ssp_str(buffer);
-
diff --git a/libs/ibrdtn/patches/040-Add-operator-to-BundleID-and-MetaBundle.patch b/libs/ibrdtn/patches/040-Add-operator-to-BundleID-and-MetaBundle.patch
deleted file mode 100644
index 2f5611111..000000000
--- a/libs/ibrdtn/patches/040-Add-operator-to-BundleID-and-MetaBundle.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From a5b9c2feeaabbd90c9734c5d865d471eed0d5e3a Mon Sep 17 00:00:00 2001
-From: Rosen Penev <rosenp@gmail.com>
-Date: Thu, 28 Mar 2019 01:55:15 -0700
-Subject: [PATCH] Add operator!=() to BundleID and MetaBundle
-
-Needed for uClibc++.
-
-Signed-off-by: Rosen Penev <rosenp@gmail.com>
----
- ibrdtn/data/Bundle.cpp | 10 ++++++++++
- ibrdtn/data/Bundle.h | 2 ++
- 2 files changed, 12 insertions(+)
-
---- a/ibrdtn/data/Bundle.cpp
-+++ b/ibrdtn/data/Bundle.cpp
-@@ -71,11 +71,21 @@ namespace dtn
- return other == (const PrimaryBlock&)(*this);
- }
-
-+ bool Bundle::operator!=(const BundleID& other) const
-+ {
-+ return other != (const PrimaryBlock&)(*this);
-+ }
-+
- bool Bundle::operator==(const MetaBundle& other) const
- {
- return other == (const PrimaryBlock&)(*this);
- }
-
-+ bool Bundle::operator!=(const MetaBundle& other) const
-+ {
-+ return other != (const PrimaryBlock&)(*this);
-+ }
-+
- bool Bundle::operator!=(const Bundle& other) const
- {
- return (const PrimaryBlock&)(*this) != (const PrimaryBlock&)other;
---- a/ibrdtn/data/Bundle.h
-+++ b/ibrdtn/data/Bundle.h
-@@ -97,7 +97,9 @@ namespace dtn
- virtual ~Bundle();
-
- bool operator==(const BundleID& other) const;
-+ bool operator!=(const BundleID& other) const;
- bool operator==(const MetaBundle& other) const;
-+ bool operator!=(const MetaBundle& other) const;
-
- bool operator==(const Bundle& other) const;
- bool operator!=(const Bundle& other) const;
diff --git a/libs/libndpi/Makefile b/libs/libndpi/Makefile
index 3e12d45b0..bc4437dfa 100644
--- a/libs/libndpi/Makefile
+++ b/libs/libndpi/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libndpi
PKG_VERSION:=3.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/ntop/nDPI/tar.gz/$(PKG_VERSION)?
@@ -25,7 +25,6 @@ PKG_REMOVE_FILES:=autogen.sh
PKG_BUILD_DEPENDS:=libpcap
PKG_BUILD_PARALLEL:=1
-include $(INCLUDE_DIR)/uclibc++.mk
include $(INCLUDE_DIR)/package.mk
ifeq ($(CONFIG_LIBNDPI_GCRYPT),)
@@ -37,7 +36,7 @@ define Package/libndpi
CATEGORY:=Libraries
TITLE:=Library for deep-packet inspection
URL:=https://github.com/ntop/nDPI
- DEPENDS:=$(CXX_DEPENDS) +LIBNDPI_GCRYPT:libgcrypt +libpcap +libjson-c
+ DEPENDS:=+LIBNDPI_GCRYPT:libgcrypt +libpcap +libjson-c
endef
define Package/libndpi/description
diff --git a/libs/libplist/Makefile b/libs/libplist/Makefile
index 73595a77e..d5cbc0e94 100644
--- a/libs/libplist/Makefile
+++ b/libs/libplist/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libplist
PKG_VERSION:=2.2.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://www.libimobiledevice.org/downloads
@@ -21,7 +21,6 @@ PKG_CPE_ID:=cpe:/a:libimobiledevice:libplist
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
-include $(INCLUDE_DIR)/uclibc++.mk
include $(INCLUDE_DIR)/package.mk
define Package/libplist/Default
@@ -48,21 +47,6 @@ define Package/libplist/description
$(call Package/libplist/Default/description)
endef
-define Package/libplistcxx
- $(call Package/libplist/Default)
- SECTION:=libs
- CATEGORY:=Libraries
- DEPENDS:=+libplist $(CXX_DEPENDS)
- TITLE+= C++ library
- PKG_LICENSE:=LGPL-2.1-or-later
- PKG_LICENSE_FILES:=COPYING.LESSER
-endef
-
-define Package/libplistcxx/description
- $(call Package/libplist/Default/description)
- This package contains the libplist C++ shared library.
-endef
-
define Package/plistutil
$(call Package/libplist/Default)
SECTION:=utils
@@ -83,7 +67,6 @@ CONFIGURE_ARGS += \
--without-cython
TARGET_CFLAGS += -flto
-TARGET_CXXFLAGS += -std=c++11 -fno-rtti
TARGET_LDFLAGS += -Wl,--gc-sections
define Build/InstallDev
@@ -92,9 +75,7 @@ define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libplist-2.0*.so* $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libplist++-2.0.pc $(1)/usr/lib/pkgconfig/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libplist-2.0.pc $(1)/usr/lib/pkgconfig/
- $(LN) libplist++-2.0.pc $(1)/usr/lib/pkgconfig/libplist++.pc
$(LN) libplist-2.0.pc $(1)/usr/lib/pkgconfig/libplist.pc
endef
@@ -103,16 +84,10 @@ define Package/libplist/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libplist-2.0.so.* $(1)/usr/lib/
endef
-define Package/libplistcxx/install
- $(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libplist++-2.0.so.* $(1)/usr/lib/
-endef
-
define Package/plistutil/install
$(INSTALL_DIR) $(1)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/plistutil $(1)/usr/bin/
endef
$(eval $(call BuildPackage,libplist))
-$(eval $(call BuildPackage,libplistcxx))
$(eval $(call BuildPackage,plistutil))
diff --git a/libs/libv4l/Makefile b/libs/libv4l/Makefile
index 4f11a0152..181fe529c 100644
--- a/libs/libv4l/Makefile
+++ b/libs/libv4l/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=v4l-utils
PKG_VERSION:=1.20.0
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://www.linuxtv.org/downloads/v4l-utils
@@ -22,7 +22,6 @@ PKG_BUILD_PARALLEL:=1
PKG_BUILD_DEPENDS:=!USE_GLIBC:argp-standalone
-include $(INCLUDE_DIR)/uclibc++.mk
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk
@@ -65,7 +64,7 @@ define Package/v4l-utils
SECTION:=utils
CATEGORY:=Utilities
TITLE+= utilities
- DEPENDS:= +libv4l $(CXX_DEPENDS) $(ICONV_DEPENDS) $(INTL_DEPENDS)
+ DEPENDS:= +libv4l +libstdcpp $(ICONV_DEPENDS) $(INTL_DEPENDS)
LICENSE:=GPL-2.0-or-later
LICENSE_FILES:=COPYING
endef
diff --git a/libs/tiff/Makefile b/libs/tiff/Makefile
index 837fa5470..95c45d471 100644
--- a/libs/tiff/Makefile
+++ b/libs/tiff/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=tiff
PKG_VERSION:=4.2.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://download.osgeo.org/libtiff
@@ -21,9 +21,7 @@ PKG_LICENSE_FILES:=COPYRIGHT
PKG_CPE_ID:=cpe:/a:libtiff:libtiff
PKG_BUILD_PARALLEL:=1
-PKG_CONFIG_DEPENDS:=CONFIG_PACKAGE_libtiffxx
-include $(INCLUDE_DIR)/uclibc++.mk
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
@@ -41,15 +39,6 @@ $(call Package/tiff/Default)
ABI_VERSION:=5
endef
-define Package/libtiffxx
-$(call Package/tiff/Default)
- SECTION:=libs
- CATEGORY:=Libraries
- TITLE+= library(c++ bindings)
- DEPENDS:=+libtiff $(CXX_DEPENDS)
- ABI_VERSION:=5
-endef
-
define Package/tiff-utils
$(call Package/tiff/Default)
SECTION:=utils
@@ -77,7 +66,7 @@ CMAKE_OPTIONS += \
-Dzstd=OFF \
-Dwebp=OFF \
-Djpeg12=OFF \
- -Dcxx=O$(if $(CONFIG_PACKAGE_libtiffxx),N,FF)
+ -Dcxx=OFF
TARGET_CFLAGS += $(TARGET_CPPFLAGS)
@@ -92,16 +81,10 @@ define Package/libtiff/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libtiff.so.$(ABI_VERSION)* $(1)/usr/lib
endef
-define Package/libtiffxx/install
- $(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libtiffxx.so.$(ABI_VERSION)* $(1)/usr/lib/
-endef
-
define Package/tiff-utils/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
endef
$(eval $(call BuildPackage,libtiff))
-$(eval $(call BuildPackage,libtiffxx))
$(eval $(call BuildPackage,tiff-utils))
diff --git a/libs/vips/Makefile b/libs/vips/Makefile
index da6401db7..e13a9b503 100644
--- a/libs/vips/Makefile
+++ b/libs/vips/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=vips
PKG_VERSION:=8.10.5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/libvips/libvips/releases/download/v$(PKG_VERSION)
@@ -22,7 +22,6 @@ PKG_FIXUP:=autoreconf
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
-include $(INCLUDE_DIR)/uclibc++.mk
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk
@@ -32,7 +31,7 @@ define Package/vips
CATEGORY:=Multimedia
TITLE:=An image manipulation library
URL:=https://libvips.github.io/libvips/
- DEPENDS:=+glib2 +libexif +libexpat +libjpeg +libpng +giflib +libxml2 $(CXX_DEPENDS) $(INTL_DEPENDS)
+ DEPENDS:=+glib2 +libexif +libexpat +libjpeg +libpng +giflib +libxml2 +libstdcpp $(INTL_DEPENDS)
endef
CONFIGURE_ARGS += \