aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2018-04-17 19:57:42 +0300
committerGitHub <noreply@github.com>2018-04-17 19:57:42 +0300
commit3e8ac27f3d5bac35428099b2a70b9f31dc338c86 (patch)
treea40975823935d3a04031544891e3c31ec1d1d271 /libs
parent6779bd73eb0bda347b13e6cc6df159da851e25d5 (diff)
parent9c09ecf437087d4ed0001c361f281e099677816c (diff)
Merge pull request #5921 from ClaymorePT/boost_1.67.0
boost: Package Version Update -> 1.67.0
Diffstat (limited to 'libs')
-rw-r--r--libs/boost/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/libs/boost/Makefile b/libs/boost/Makefile
index d9040922d..b586829fe 100644
--- a/libs/boost/Makefile
+++ b/libs/boost/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2015-2017 OpenWrt.org
+# Copyright (C) 2015-2018 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -16,15 +16,15 @@ include $(INCLUDE_DIR)/nls.mk
include $(INCLUDE_DIR)/target.mk
PKG_NAME:=boost
-PKG_VERSION:=1.66.0
-PKG_SOURCE_VERSION:=1_66_0
+PKG_VERSION:=1.67.0
+PKG_SOURCE_VERSION:=1_67_0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)_$(PKG_SOURCE_VERSION).tar.bz2
PKG_SOURCE_URL:=https://sourceforge.net/projects/boost/files/boost/$(PKG_VERSION)
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_$(PKG_SOURCE_VERSION)
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)_$(PKG_SOURCE_VERSION)
-PKG_HASH:=5721818253e6a0989583192f96782c4a98eb6204965316df9f5ad75819225ca9
+PKG_HASH:=2684c972994ee57fc5632e03bf044746f6eb45d4920c343937a465fd67a5adba
PKG_LICENSE:=Boost Software License <http://www.boost.org/users/license.html>
PKG_MAINTAINER:=Carlos M. Ferreira <carlosmf.pt@gmail.com>
@@ -44,7 +44,7 @@ define Package/boost/Default
endef
define Package/boost/description
-This package provides the Boost v1.66.0 libraries.
+This package provides the Boost v1.67.0 libraries.
Boost is a set of free, peer-reviewed, portable C++ source libraries.
-----------------------------------------------------------------------------
@@ -90,7 +90,7 @@ This package provides the following run-time libraries:
- wave
There are many more header-only libraries supported by Boost.
-See more at http://www.boost.org/doc/libs/1_66_0/
+See more at http://www.boost.org/doc/libs/1_67_0/
endef
PKG_BUILD_DEPENDS:=boost/host PACKAGE_python:python PACKAGE_python3:python3
@@ -301,6 +301,7 @@ $(eval $(call DefineBoostLibrary,atomic,system,))
$(eval $(call DefineBoostLibrary,chrono,system,))
$(eval $(call DefineBoostLibrary,container,,))
$(eval $(call DefineBoostLibrary,context,chrono system thread,))
+$(eval $(call DefineBoostLibrary,contract,system,))
$(eval $(call DefineBoostLibrary,coroutine,system chrono context thread,))
$(eval $(call DefineBoostLibrary,date_time,,))
#$(eval $(call DefineBoostLibrary,exception,,))