aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorTibor Dudlák <tdudlak@redhat.com>2018-01-11 09:58:14 +0100
committerTibor Dudlák <tdudlak@redhat.com>2018-02-12 22:54:50 +0100
commit3c4e99ced49f4358d43aa53d4cbf94ac4e67d139 (patch)
treef441cf8644138b7bfd6938cbdd3380480e07e47b /libs
parent59c979d595f21152c313fa895ba62c8a6b3891e9 (diff)
libhttp-parser: Bump package version and update link to GitHub
Bumped package version. There was an issue with .so file: dependent package wanted lib.so.2.8 but there was only lib.so.2.8.0 there so one more symlink added. http-parser sources are owned by nodejs now. Signed-off-by: Tibor Dudlák <tdudlak@redhat.com>
Diffstat (limited to 'libs')
-rw-r--r--libs/libhttp-parser/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/libs/libhttp-parser/Makefile b/libs/libhttp-parser/Makefile
index 3667b2beb..94cf8a1d1 100644
--- a/libs/libhttp-parser/Makefile
+++ b/libs/libhttp-parser/Makefile
@@ -8,16 +8,16 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libhttp-parser
-PKG_VERSION:=2.7.1
+PKG_VERSION:=2.8.0
PKG_RELEASE=1
PKG_MAINTAINER:=Ramanathan Sivagurunathan <ramzthecoder@gmail.com>
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE-MIT
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_MIRROR_HASH:=20e6acc415ae8a47f39c6821685dbba09d99ff5079902fe1a0f580c2c88ae18a
+PKG_MIRROR_HASH:=83acea397da4cdb9192c27abbd53a9eb8e5a9e1bcea2873b499f7ccc0d68f518
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_URL:=git://github.com/joyent/http-parser.git
+PKG_SOURCE_URL:=git://github.com/nodejs/http-parser.git
PKG_SOURCE_PROTO:=git
PKG_SOURCE_VERSION:=v$(PKG_VERSION)
@@ -28,7 +28,7 @@ define Package/libhttp-parser
SECTION:=libs
CATEGORY:=Libraries
TITLE:=A library to parse http request and response
- URL:=https://github.com/joyent/http-parser
+ URL:=https://github.com/nodejs/http-parser
endef
define Package/libhttp-parser/description
@@ -49,13 +49,17 @@ define Build/InstallDev
$(INSTALL_DATA) $(PKG_BUILD_DIR)/http_parser.h $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
$(INSTALL_DATA) $(PKG_BUILD_DIR)/libhttp_parser.so.* $(1)/usr/lib/
- ( cd $(1)/usr/lib ; ln -s libhttp_parser.so.* libhttp_parser.so )
+ ( cd $(1)/usr/lib ; \
+ ln -s libhttp_parser.so.$(PKG_VERSION) libhttp_parser.so ; \
+ ln -s libhttp_parser.so.$(PKG_VERSION) libhttp_parser.so.2.8 )
endef
define Package/libhttp-parser/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_BUILD_DIR)/libhttp_parser.so.* $(1)/usr/lib/
- ( cd $(1)/usr/lib ; ln -s libhttp_parser.so.* libhttp_parser.so )
+ ( cd $(1)/usr/lib ; \
+ ln -s libhttp_parser.so.$(PKG_VERSION) libhttp_parser.so ; \
+ ln -s libhttp_parser.so.$(PKG_VERSION) libhttp_parser.so.2.8 )
endef
$(eval $(call BuildPackage,libhttp-parser))