aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-04-10 13:21:03 -0700
committerGitHub <noreply@github.com>2019-04-10 13:21:03 -0700
commit3bd227ab2147d6e0e60f20fa0ca6e0fe47a349a4 (patch)
treee7729cbce1d923eec30d3f09c8a595935bb911d2 /libs
parent919626143e467b5976932a7d791ab2cd43219323 (diff)
parentb40718dcbccb99cbbc0558e53ead47e15cca327b (diff)
Merge pull request #8645 from sartura/protobuf-c-x86-build-fail-fix
protobuf-c: fix x86 build fail
Diffstat (limited to 'libs')
-rw-r--r--libs/protobuf-c/Makefile2
-rw-r--r--libs/protobuf-c/patches/001-t-generated-code2-cxx-generate-packed-data-fix.patch13
2 files changed, 14 insertions, 1 deletions
diff --git a/libs/protobuf-c/Makefile b/libs/protobuf-c/Makefile
index 6199766c3..e04483318 100644
--- a/libs/protobuf-c/Makefile
+++ b/libs/protobuf-c/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libprotobuf-c
PKG_VERSION:=1.3.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=protobuf-c-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/protobuf-c/protobuf-c/releases/download/v$(PKG_VERSION)
diff --git a/libs/protobuf-c/patches/001-t-generated-code2-cxx-generate-packed-data-fix.patch b/libs/protobuf-c/patches/001-t-generated-code2-cxx-generate-packed-data-fix.patch
new file mode 100644
index 000000000..2d83cec59
--- /dev/null
+++ b/libs/protobuf-c/patches/001-t-generated-code2-cxx-generate-packed-data-fix.patch
@@ -0,0 +1,13 @@
+Index: protobuf-c-1.3.1/t/generated-code2/cxx-generate-packed-data.cc
+===================================================================
+--- protobuf-c-1.3.1.orig/t/generated-code2/cxx-generate-packed-data.cc
++++ protobuf-c-1.3.1/t/generated-code2/cxx-generate-packed-data.cc
+@@ -998,7 +998,7 @@ static void dump_test_packed_repeated_en
+ static void dump_test_unknown_fields (void)
+ {
+ EmptyMess mess;
+- const google::protobuf::Message::Reflection *reflection = mess.GetReflection();
++ const google::protobuf::Reflection *reflection = mess.GetReflection();
+ google::protobuf::UnknownFieldSet *fs = reflection->MutableUnknownFields(&mess);
+
+ #if GOOGLE_PROTOBUF_VERSION >= 2001000