aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-01-10 18:36:33 -0800
committerRosen Penev <rosenp@gmail.com>2020-01-10 18:37:18 -0800
commit3a559224b3406158888c9590f3a808606094b4da (patch)
treef72ef23bbaf9f16460904cc72c8e0d762f52c9eb /libs
parentcb63deb8e9c473e4afeac940284fc2fb88a13eee (diff)
libcap: Fix compilation with uClibc-ng
The test does not compile with --static. As this does not touch binaries, not bumping the package release. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs')
-rw-r--r--libs/libcap/patches/300-uclibc-ng.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/libs/libcap/patches/300-uclibc-ng.patch b/libs/libcap/patches/300-uclibc-ng.patch
new file mode 100644
index 000000000..616d2725d
--- /dev/null
+++ b/libs/libcap/patches/300-uclibc-ng.patch
@@ -0,0 +1,11 @@
+--- a/tests/Makefile
++++ b/tests/Makefile
+@@ -32,7 +32,7 @@ run_libcap_psx_test: libcap_psx_test
+ ./libcap_psx_test
+
+ libcap_psx_test: libcap_psx_test.c $(DEPS)
+- $(CC) $(CFLAGS) $(IPATH) $< -o $@ $(LIBCAPLIB) $(LIBPSXLIB) -Wl,-wrap,pthread_create --static
++ $(CC) $(CFLAGS) $(IPATH) $< -o $@ $(LIBCAPLIB) $(LIBPSXLIB) -Wl,-wrap,pthread_create
+
+ clean:
+ rm -f psx_test psx_test_wrap libcap_psx_test