aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-06-19 22:39:07 -0700
committerRosen Penev <rosenp@gmail.com>2020-06-19 23:16:33 -0700
commit38ea3e84f8c127f38ed4a2cdb1ee0f5d0b3848f9 (patch)
treee19a2a851cae325fe35d43aab11189bd9c9cd51d /libs
parentd082258c3eb6305dd11429f4d41e42ac2d91234f (diff)
libusbmuxd: update to 2.0.2
Upstream created proper tarballs. Switched to those. Removed autoreconf as a result. Adjusted filenames. Got rid of static compiles as they're pretty useless. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs')
-rw-r--r--libs/libusbmuxd/Makefile20
-rw-r--r--libs/libusbmuxd/patches/010-select.patch10
2 files changed, 10 insertions, 20 deletions
diff --git a/libs/libusbmuxd/Makefile b/libs/libusbmuxd/Makefile
index 215660c5e..59b8d908a 100644
--- a/libs/libusbmuxd/Makefile
+++ b/libs/libusbmuxd/Makefile
@@ -8,17 +8,16 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libusbmuxd
-PKG_SOURCE_VERSION:=2.0.1
-PKG_RELEASE:=2
+PKG_VERSION:=2.0.2
+PKG_RELEASE:=1
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=https://github.com/libimobiledevice/libusbmuxd
-PKG_MIRROR_HASH:=5078125cd4fe8c7294d4f195a8adfd1fc302101daf5d53e4cc242c3097eef8b6
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=https://www.libimobiledevice.org/downloads
+PKG_HASH:=cc6a808553da4efa9fa5638be256d5ae020498795d9d260d280b87074e799b20
PKG_MAINTAINER:=Rosen Penev <rosenp@gmail.com>
PKG_CPE_ID:=cpe:/a:libimobiledevice:libusbmuxd
-PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
@@ -67,20 +66,21 @@ define Package/libusbmuxd-utils/description
This package contains the libusbmuxd utilities.
endef
-TARGET_CFLAGS += $(FPIC)
+CONFIGURE_ARGS += \
+ --disable-static
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libusbmuxd.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libusbmuxd-2.0.so* $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libusbmuxd.pc $(1)/usr/lib/pkgconfig/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libusbmuxd-2.0.pc $(1)/usr/lib/pkgconfig/
endef
define Package/libusbmuxd/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libusbmuxd.so.* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libusbmuxd-2.0.so.* $(1)/usr/lib/
endef
define Package/libusbmuxd-utils/install
diff --git a/libs/libusbmuxd/patches/010-select.patch b/libs/libusbmuxd/patches/010-select.patch
deleted file mode 100644
index 1caefdc91..000000000
--- a/libs/libusbmuxd/patches/010-select.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/tools/inetcat.c
-+++ b/tools/inetcat.c
-@@ -33,6 +33,7 @@
- #include <windows.h>
- #include <winsock2.h>
- #else
-+#include <sys/select.h>
- #include <sys/socket.h>
- #include <sys/un.h>
- #include <sys/ioctl.h>