aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-09-04 14:15:42 -0700
committerGitHub <noreply@github.com>2020-09-04 14:15:42 -0700
commit3375721197ea2a953e041990c655a941852724f3 (patch)
treed5383fbc80f773e6a68d95674895e9f85405069e /libs
parent6333ef24c7fc550b3a2c459ac5eb8e9ea0fc0e20 (diff)
parent4f1c7c5499be9d4fb953aa82a91f3c997a790d2d (diff)
Merge pull request #13292 from neheb/lcng
libcap-ng: update to 0.7.11
Diffstat (limited to 'libs')
-rw-r--r--libs/libcap-ng/Makefile4
-rw-r--r--libs/libcap-ng/patches/add_library_if_header_found.patch30
-rw-r--r--libs/libcap-ng/patches/fix-includes.patch11
-rw-r--r--libs/libcap-ng/patches/fix_build_without_threads.patch26
4 files changed, 2 insertions, 69 deletions
diff --git a/libs/libcap-ng/Makefile b/libs/libcap-ng/Makefile
index 04d480f2b..059378f64 100644
--- a/libs/libcap-ng/Makefile
+++ b/libs/libcap-ng/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libcap-ng
-PKG_VERSION:=0.7.10
+PKG_VERSION:=0.7.11
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://people.redhat.com/sgrubb/libcap-ng
-PKG_HASH:=a84ca7b4e0444283ed269b7a29f5b6187f647c82e2b876636b49b9a744f0ffbf
+PKG_HASH:=85815c711862d01a440db471f12fba462c9949e923966f5859607e652d9c0ae9
PKG_MAINTAINER:=Lucian CRISTIAN <lucian.cristian@gmail.com>
PKG_LICENSE:=GPL-2.0-or-later LGPL-2.1-or-later
diff --git a/libs/libcap-ng/patches/add_library_if_header_found.patch b/libs/libcap-ng/patches/add_library_if_header_found.patch
deleted file mode 100644
index fbeee1cde..000000000
--- a/libs/libcap-ng/patches/add_library_if_header_found.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 2c855b76362d1027abea967ac253cae8a7c160c3 Mon Sep 17 00:00:00 2001
-From: Trevor Woerner <twoerner@gmail.com>
-Date: Wed, 6 May 2020 17:38:05 -0400
-Subject: [PATCH] configure.ac: add library if header found (#10)
-
-If the pthread.h header is found, make sure library containing
-"pthread_atfork" is added to the list of libraries against which to link.
-On some hosts (e.g. openSUSE 15.1) "-lpthread" needs to be explicitly added
-in order for the code to compile correctly.
-
-Signed-off-by: Trevor Woerner <twoerner@gmail.com>
----
- configure.ac | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index 9d6aca3..4fbe4d3 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -56,7 +56,9 @@ AC_CHECK_HEADERS(sys/xattr.h, [], [
- AC_CHECK_HEADERS(attr/xattr.h, [], [AC_MSG_WARN(attr/xattr.h not found, disabling file system capabilities.)])
- ])
- AC_CHECK_HEADERS(linux/securebits.h, [], [])
--AC_CHECK_HEADERS(pthread.h, [], [AC_MSG_WARN(pthread.h not found, disabling pthread_atfork.)])
-+AC_CHECK_HEADERS(pthread.h,
-+ [AC_SEARCH_LIBS(pthread_atfork, pthread)],
-+ [AC_MSG_WARN(pthread.h not found, disabling pthread_atfork.)])
-
- AC_C_CONST
- AC_C_INLINE
diff --git a/libs/libcap-ng/patches/fix-includes.patch b/libs/libcap-ng/patches/fix-includes.patch
deleted file mode 100644
index 8fbd984b8..000000000
--- a/libs/libcap-ng/patches/fix-includes.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -ru libcap-ng-0.7.4.orig/src/cap-ng.c libcap-ng-0.7.4/src/cap-ng.c
---- libcap-ng-0.7.4.orig/src/cap-ng.c 2014-04-24 15:41:43.000000000 -0300
-+++ libcap-ng-0.7.4/src/cap-ng.c 2015-04-15 08:45:10.783335463 -0300
-@@ -34,6 +34,7 @@
- #include <stdarg.h>
- #include <errno.h>
- #include <fcntl.h>
-+#include <endian.h>
- #include <byteswap.h>
- #ifdef HAVE_SYSCALL_H
- #include <sys/syscall.h>
diff --git a/libs/libcap-ng/patches/fix_build_without_threads.patch b/libs/libcap-ng/patches/fix_build_without_threads.patch
deleted file mode 100644
index 39a2555d1..000000000
--- a/libs/libcap-ng/patches/fix_build_without_threads.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 9b5597dc780a9da292f9142899a992cfc6ca081d Mon Sep 17 00:00:00 2001
-From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Date: Thu, 7 May 2020 00:19:18 +0200
-Subject: [PATCH] src/cap-ng.c: fix build without threads (#13)
-
-Put pthread_atfork under #ifdef HAVE_PTHREAD_H block
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
----
- src/cap-ng.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/src/cap-ng.c b/src/cap-ng.c
-index 35fcd7a..97a3dbd 100644
---- a/src/cap-ng.c
-+++ b/src/cap-ng.c
-@@ -166,7 +166,9 @@ static void deinit(void)
- static void init_lib(void) __attribute__ ((constructor));
- static void init_lib(void)
- {
-+#ifdef HAVE_PTHREAD_H
- pthread_atfork(NULL, NULL, deinit);
-+#endif
- }
-
- static void init(void)