aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-03-20 17:05:21 -0700
committerRosen Penev <rosenp@gmail.com>2021-03-26 13:14:35 -0700
commit297f34b5d9cfbb59e66c7aba01688b385deb8205 (patch)
treed51f89be2419777f865687f9dc90db0d902cf0e4 /libs
parent6aa8189393c378141250fa69ebd6a561150f4fb5 (diff)
liborcania: update to 2.2.0
Switch to AUTORELEASE for simplicity. Switch to building with Ninja for faster compilation. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs')
-rw-r--r--libs/liborcania/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/libs/liborcania/Makefile b/libs/liborcania/Makefile
index b73f6cd6d..ff14f41f1 100644
--- a/libs/liborcania/Makefile
+++ b/libs/liborcania/Makefile
@@ -6,23 +6,22 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=liborcania
-PKG_VERSION:=2.1.1
-PKG_RELEASE:=1
+PKG_VERSION:=2.2.0
+PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/babelouest/orcania/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=960074f6aa198e9db5440347d20cff8be3b82ee1c15ac7b23c0ac54a301a85cd
+PKG_HASH:=2a46460c6d93e5b8dd97db520edc1e9b3297577fdd8c485b2b6ebf315ceab6f0
PKG_MAINTAINER:=Toni Uhlig <matzeton@googlemail.com>
PKG_LICENSE:=LGPL-2.1-or-later
PKG_LICENSE_FILES:=LICENSE
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)/orcania-$(PKG_VERSION)
-PKG_BUILD_PARALLEL:=1
CMAKE_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/cmake.mk
+include ../../devel/ninja/ninja-cmake.mk
define Package/liborcania
SECTION:=libs