aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorMike Brady <mikebrady@eircom.net>2014-08-25 15:27:01 +0100
committerMike Brady <mikebrady@eircom.net>2014-08-25 15:27:01 +0100
commit2680ebcb80627e3119aba860f8f12ac0596a1455 (patch)
tree75054ac836bb6db96d9b8cd2818ab0cf723820cb /libs
parent30bbf62cb6f7d802aa1b43d928354c4b8713cce7 (diff)
Add libsoxr -- it performs one-dimensional sample-rate conversion
Diffstat (limited to 'libs')
-rw-r--r--libs/libsoxr/Makefile61
-rwxr-xr-xlibs/libsoxr/files/configure1
2 files changed, 62 insertions, 0 deletions
diff --git a/libs/libsoxr/Makefile b/libs/libsoxr/Makefile
new file mode 100644
index 000000000..98a0f0f5d
--- /dev/null
+++ b/libs/libsoxr/Makefile
@@ -0,0 +1,61 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+# updated to work with latest source from abrasive
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libsoxr
+PKG_VERSION:=0.1.1
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=git://git.code.sf.net/p/soxr/code
+PKG_SOURCE_VERSION:=HEAD
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+
+PKG_FIXUP:=libtool
+PKG_REMOVE_FILES:=autogen.sh
+
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Build/Configure
+ $(CP) ./files/* $(PKG_BUILD_DIR)/
+ $(call Build/Configure/Default, )
+endef
+
+define Package/libsoxr
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=The SoX Resampler library
+ URL:=http://sourceforge.net/projects/soxr/
+ MAINTAINER:=Mike Brady <mikebrady@eircom.net>
+ DEPENDS:= +libpthread
+endef
+
+define Package/libsoxr/description
+ The SoX Resampler library
+ High quality, one-dimensional sample-rate conversion library
+endef
+
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_BUILD_DIR)/src/soxr.h $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/src/*.a $(1)/usr/lib/
+endef
+
+define Package/libsoxr/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/src/*.a $(1)/usr/lib/
+endef
+
+
+$(eval $(call BuildPackage,libsoxr))
diff --git a/libs/libsoxr/files/configure b/libs/libsoxr/files/configure
new file mode 100755
index 000000000..0cf7857d3
--- /dev/null
+++ b/libs/libsoxr/files/configure
@@ -0,0 +1 @@
+cmake -DBUILD_SHARED_LIBS=OFF -DBUILD_TESTS=0 -DBUILD_EXAMPLES=0 .