aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-03-20 14:57:29 -0700
committerRosen Penev <rosenp@gmail.com>2021-03-24 15:40:24 -0700
commit263802c6a255b746c7d342ee705199fee69caa8a (patch)
tree62255b60bf4b7c4792dd86543c7fdb136a47da71 /libs
parent82edde6a0dc8036f28573ada4cb0a24299af9a13 (diff)
gost_engine: fix compilation without deprecated OpenSSL APIs
Build with Ninja for faster compilation. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs')
-rw-r--r--libs/gost_engine/Makefile2
-rw-r--r--libs/gost_engine/patches/010-openssl-deprecated.patch11
2 files changed, 12 insertions, 1 deletions
diff --git a/libs/gost_engine/Makefile b/libs/gost_engine/Makefile
index 00b55e7c2..28fde5b8b 100644
--- a/libs/gost_engine/Makefile
+++ b/libs/gost_engine/Makefile
@@ -12,7 +12,7 @@ PKG_MAINTAINER:=Artur Petrov <github@phpchain.ru>
PKG_LICENSE:=OpenSSL
include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/cmake.mk
+include ../../devel/ninja/ninja-cmake.mk
PKG_UNPACK:=$(HOST_TAR) -C "$(PKG_BUILD_DIR)" --strip-components=1 -xzf "$(DL_DIR)/$(PKG_SOURCE)"
PKG_INSTALL:=
diff --git a/libs/gost_engine/patches/010-openssl-deprecated.patch b/libs/gost_engine/patches/010-openssl-deprecated.patch
new file mode 100644
index 000000000..c28748a91
--- /dev/null
+++ b/libs/gost_engine/patches/010-openssl-deprecated.patch
@@ -0,0 +1,11 @@
+--- a/gost_pmeth.c
++++ b/gost_pmeth.c
+@@ -608,7 +608,7 @@ static int pkey_gost_mac_ctrl_str(EVP_PK
+ if (strcmp(type, hexkey_ctrl_string) == 0) {
+ long keylen;
+ int ret;
+- unsigned char *keybuf = string_to_hex(value, &keylen);
++ unsigned char *keybuf = OPENSSL_hexstr2buf(value, &keylen);
+ if (!keybuf || keylen != 32) {
+ GOSTerr(GOST_F_PKEY_GOST_MAC_CTRL_STR,
+ GOST_R_INVALID_MAC_KEY_LENGTH);