aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorchamptar <champetier.etienne@gmail.com>2017-09-14 17:48:31 -0700
committerGitHub <noreply@github.com>2017-09-14 17:48:31 -0700
commit24fb67a70d79426d7ec7b1daea437ce1f5d4ea03 (patch)
tree99e178107d7aeadd02cb9d647b6c8006ccfaf366 /libs
parent837b464cfd1f2949c4e7ea91110c52dc09cb578f (diff)
parent4d94943818e918676a161a218b0778ad14c30471 (diff)
Merge pull request #4708 from commodo/python-cffi-fix
libffi: fix location of host side headers ; python,python3: set correct build flags to host pip build
Diffstat (limited to 'libs')
-rw-r--r--libs/libffi/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/libs/libffi/Makefile b/libs/libffi/Makefile
index b0376d441..be1763c93 100644
--- a/libs/libffi/Makefile
+++ b/libs/libffi/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libffi
PKG_VERSION:=3.2.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://sourceware.org/pub/libffi/
@@ -78,5 +78,15 @@ define Package/libffi/install
$(1)/usr/lib/
endef
+define Host/Install
+ $(call Host/Install/Default)
+ # Adjust host libffi headers ; the default rule does
+ # not seem to install them to the proper include folder
+ $(INSTALL_DIR) $(STAGING_DIR_HOSTPKG)/include
+ $(CP) \
+ $(STAGING_DIR_HOSTPKG)/lib/libffi-$(PKG_VERSION)/include/*.h \
+ $(STAGING_DIR_HOSTPKG)/include
+endef
+
$(eval $(call HostBuild))
$(eval $(call BuildPackage,libffi))