aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-04-04 14:07:04 -0700
committerRosen Penev <rosenp@gmail.com>2020-04-09 00:57:28 -0700
commit1f1d4db6945236b5b499f654b9bf5aa2b6cec953 (patch)
tree2cd91c608d3537ed7a70781134f923c253664517 /libs
parent5911707366a6ebcee16785f2b58745e22f9ccd85 (diff)
libfizz: remove
Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs')
-rw-r--r--libs/libfizz/Makefile49
-rw-r--r--libs/libfizz/patches/010-no-boost-thread.patch11
2 files changed, 0 insertions, 60 deletions
diff --git a/libs/libfizz/Makefile b/libs/libfizz/Makefile
deleted file mode 100644
index 2b62e3c2f..000000000
--- a/libs/libfizz/Makefile
+++ /dev/null
@@ -1,49 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=libfizz
-PKG_VERSION:=2019.10.07.00
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://codeload.github.com/facebookincubator/fizz/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=acf0184466b518dd58d02dc04211aac1c4504bb3ff6d9e8454af5ac2bc85fa6c
-PKG_BUILD_DIR:=$(BUILD_DIR)/fizz-$(PKG_VERSION)
-
-PKG_MAINTAINER:=Amol Bhave <ambhave@fb.com>
-PKG_LICENSE:=BSD-3-Clause
-PKG_LICENSE_FILES:=LICENSE
-PKG_CPE_ID:=cpe:/a:facebook:fizz
-
-PKG_BUILD_PARALLEL:=1
-CMAKE_SOURCE_SUBDIR:=fizz
-CMAKE_INSTALL:=1
-
-include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/cmake.mk
-
-define Package/libfizz
- SECTION:=libs
- CATEGORY:=Libraries
- DEPENDS:=+libfolly
- TITLE:=C++14 implementation of the TLS-1.3 standard
- URL:=https://github.com/facebookincubator/fizz
-endef
-
-define Package/libfizz/description
- C++14 implementation of the TLS-1.3 standard.
- Fizz currently supports TLS 1.3 drafts 28, 26 (both wire-compatible with the final specification), and 23.
-endef
-
-CMAKE_OPTIONS += \
- -DBUILD_EXAMPLES=OFF \
- -DBUILD_SHARED_LIBS=ON
-
-TARGET_CXXFLAGS += -ffunction-sections -fdata-sections -flto
-TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed
-
-define Package/libfizz/install
- $(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfizz.so* $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,libfizz))
diff --git a/libs/libfizz/patches/010-no-boost-thread.patch b/libs/libfizz/patches/010-no-boost-thread.patch
deleted file mode 100644
index 3a503d0fa..000000000
--- a/libs/libfizz/patches/010-no-boost-thread.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/fizz/CMakeLists.txt
-+++ b/fizz/CMakeLists.txt
-@@ -52,7 +52,7 @@ if (NOT folly_FOUND)
- find_package(Folly MODULE REQUIRED)
- endif()
-
--find_package(Boost REQUIRED COMPONENTS system thread filesystem regex context
-+find_package(Boost REQUIRED COMPONENTS system filesystem regex context
- program_options)
- find_package(OpenSSL REQUIRED)
- find_package(Glog REQUIRED)