aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorPaul Fertser <fercerpav@gmail.com>2023-01-20 14:54:59 +0000
committerRosen Penev <rosenp@gmail.com>2023-01-20 17:44:14 -0800
commit1e8584dc581567d12c9f4fcb1e1dd29b7a189ae9 (patch)
tree1efeeb89db6debb67e3e750fc8636925df0c1a7e /libs
parentdd48483a60080ea5f3b83d5d4c71a9ac7b27043b (diff)
treewide: quote CC and CXX
When CC is set to e.g. "ccache mips-openwrt-linux-musl-gcc" it needs to be quoted to avoid word splitting on substitution. Signed-off-by: Paul Fertser <fercerpav@gmail.com>
Diffstat (limited to 'libs')
2 files changed, 3 insertions, 3 deletions
diff --git a/libs/liburing/Makefile b/libs/liburing/Makefile
index 6eb84b18d..445e535ad 100644
--- a/libs/liburing/Makefile
+++ b/libs/liburing/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=liburing
PKG_VERSION:=2.3
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://git.kernel.dk/cgit/liburing/snapshot
@@ -32,7 +32,7 @@ define Package/liburing/description
For more info on io_uring, please see: https://kernel.dk/io_uring.pdf
endef
-CONFIGURE_ARGS:=--prefix=$(CONFIGURE_PREFIX) --cc=${TARGET_CC}
+CONFIGURE_ARGS:=--prefix=$(CONFIGURE_PREFIX) --cc="${TARGET_CC}"
define Build/Compile
$(MAKE) $(PKG_BUILD_DIR) \
diff --git a/libs/pcapplusplus/Makefile b/libs/pcapplusplus/Makefile
index af44583a1..63d52f1a4 100644
--- a/libs/pcapplusplus/Makefile
+++ b/libs/pcapplusplus/Makefile
@@ -32,7 +32,7 @@ endef
define Build/Compile
cd $(PKG_BUILD_DIR)/PcapPlusPlus; ./configure-linux.sh --install-dir /usr
- make -C $(PKG_BUILD_DIR)/PcapPlusPlus CXXFLAGS="$(TARGET_CXXFLAGS) -fPIC" CFLAGS="$(TARGET_CFLAGS) -fPIC" CXX=$(TARGET_CXX) CC=$(TARGET_CC) AR=$(TARGET_AR) libs
+ make -C $(PKG_BUILD_DIR)/PcapPlusPlus CXXFLAGS="$(TARGET_CXXFLAGS) -fPIC" CFLAGS="$(TARGET_CFLAGS) -fPIC" CXX="$(TARGET_CXX)" CC="$(TARGET_CC)" AR=$(TARGET_AR) libs
endef
define Build/InstallDev