aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorSebastian Kemper <sebastian_ml@gmx.net>2020-05-11 22:14:54 +0200
committerSebastian Kemper <sebastian_ml@gmx.net>2020-05-11 22:15:01 +0200
commit19de52a044e336b3f2acb06d9c20ea3044f538ee (patch)
treeae2abb3548898dab04825bf362d8a5e202b0fcb0 /libs
parent59b91fc342aa69c8aa107587fd29ff2161159c65 (diff)
mariadb: install config files readable for all
Until now $(INSTALL_CONF) is used for configuration files that go into /etc/mysql. This commit replaces that with $(INSTALL_DATA). The configuration files are not only parsed by the server, but also by the clients (which can be anybody). This also removes a comment about a cron job from one of the configuration files. There is no cron job. Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
Diffstat (limited to 'libs')
-rw-r--r--libs/libmariadb/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/libs/libmariadb/Makefile b/libs/libmariadb/Makefile
index db9d259e7..64c849edf 100644
--- a/libs/libmariadb/Makefile
+++ b/libs/libmariadb/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libmariadb
PKG_VERSION:=3.1.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=mariadb-connector-c-$(PKG_VERSION)-src.tar.gz
PKG_SOURCE_URL := \
@@ -160,7 +160,7 @@ define Package/$(PKG_NAME)/install
$(PKG_INSTALL_DIR)$(MARIADB_PLUGIN_DIR)/sha256_password.so \
$(1)$(MARIADB_PLUGIN_DIR)
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/libmariadb.so.$(ABI_VERSION) $(1)/usr/lib
- $(INSTALL_CONF) conf/50-client.cnf $(1)$(MARIADB_CONF_DIR)/conf.d
+ $(INSTALL_DATA) conf/50-client.cnf $(1)$(MARIADB_CONF_DIR)/conf.d
endef
define BuildPlugin