aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2023-05-16 22:02:20 +0800
committerTianling Shen <cnsztl@gmail.com>2023-05-17 09:24:45 +0800
commit18cfa22c654da757f61823a6c3f21384980ea008 (patch)
tree6f3a37f97b1d4216d880fc2e10759dab177b1f0b /libs
parentfeaba4f52bc902a9ee1f4980d84377a67a15117a (diff)
alsa-lib: Update to 1.2.9
* updated source url (prefer https rather than http/ftp) * refreshed patches Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
Diffstat (limited to 'libs')
-rw-r--r--libs/alsa-lib/Makefile10
-rw-r--r--libs/alsa-lib/patches/200-usleep.patch6
2 files changed, 8 insertions, 8 deletions
diff --git a/libs/alsa-lib/Makefile b/libs/alsa-lib/Makefile
index 1efd068a1..d9922b35f 100644
--- a/libs/alsa-lib/Makefile
+++ b/libs/alsa-lib/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=alsa-lib
-PKG_VERSION:=1.2.6.1
-PKG_RELEASE:=3
+PKG_VERSION:=1.2.9
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/lib/ \
- http://distfiles.gentoo.org/distfiles/
-PKG_HASH:=ad582993d52cdb5fb159a0beab60a6ac57eab0cc1bdf85dc4db6d6197f02333f
+PKG_SOURCE_URL:=https://www.alsa-project.org/files/pub/lib/ \
+ https://distfiles.gentoo.org/distfiles/
+PKG_HASH:=dc9c643fdc4ccfd0572cc685858dd41e08afb583f30460b317e4188275f615b2
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>, \
Peter Wagner <tripolar@gmx.at>
diff --git a/libs/alsa-lib/patches/200-usleep.patch b/libs/alsa-lib/patches/200-usleep.patch
index 7551584a8..9e66ef8ba 100644
--- a/libs/alsa-lib/patches/200-usleep.patch
+++ b/libs/alsa-lib/patches/200-usleep.patch
@@ -17,9 +17,9 @@
const char *_snd_module_pcm_shm = "";
--- a/src/ucm/ucm_local.h
+++ b/src/ucm/ucm_local.h
-@@ -58,6 +58,14 @@
- #define SEQUENCE_ELEMENT_TYPE_SYSSET 11
- #define SEQUENCE_ELEMENT_TYPE_CFGSAVE 12
+@@ -61,6 +61,14 @@
+ #define SEQUENCE_ELEMENT_TYPE_DEV_DISABLE_SEQ 14
+ #define SEQUENCE_ELEMENT_TYPE_DEV_DISABLE_ALL 15
+#if _POSIX_C_SOURCE >= 200809L
+#define usleep(a) \