aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorKarl Palsson <karlp@etactica.com>2021-08-03 15:26:26 +0000
committerKarl Palsson <karlp@etactica.com>2021-08-03 17:29:16 +0000
commit1557ac367a4fd5cdd33ec53a36d075fe001aeb8c (patch)
tree9026869603cd6368e1ee27de134101893546202e /libs
parent0e186bd5119cffbf5c3dfa88851ef6051873adcf (diff)
libwebsockets: enable built in uloop support
uloop is always available on OpenWrt, so build in LWS's uloop support by default. Size difference of .ipk is 683 bytes, or about 0.5%. No known applications use this at present, but it seems better to proactively offer it. Signed-off-by: Karl Palsson <karlp@etactica.com>
Diffstat (limited to 'libs')
-rw-r--r--libs/libwebsockets/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/libs/libwebsockets/Makefile b/libs/libwebsockets/Makefile
index fdfc3e551..df1f0a4d2 100644
--- a/libs/libwebsockets/Makefile
+++ b/libs/libwebsockets/Makefile
@@ -29,6 +29,7 @@ include $(INCLUDE_DIR)/cmake.mk
CMAKE_OPTIONS += -DLWS_IPV6=$(if $(CONFIG_IPV6),ON,OFF)
CMAKE_OPTIONS += -DISABLE_WERROR=ON
CMAKE_OPTIONS += -DCMAKE_BUILD_TYPE=Release
+CMAKE_OPTIONS += -DLWS_WITH_ULOOP=ON
# turn off all test apps
CMAKE_OPTIONS += -DLWS_WITHOUT_TESTAPPS=ON