aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorsbyx <steven@midlink.org>2014-08-25 16:46:36 +0200
committersbyx <steven@midlink.org>2014-08-25 16:46:36 +0200
commit1310ac58969d42988837ff275f49cc30340721ac (patch)
treed850947ae96e3d95feb84186f001794b30d44b44 /libs
parent30bbf62cb6f7d802aa1b43d928354c4b8713cce7 (diff)
parent1dc00a2b0a451909dcf8b97ba192558d88a0e2ab (diff)
Merge pull request #236 from ejonny/libarchive-reduce-dependencies
libarchive: Reduce dependencies by disabling them using configure args
Diffstat (limited to 'libs')
-rw-r--r--libs/libarchive/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/libs/libarchive/Makefile b/libs/libarchive/Makefile
index b673111bc..1693cd015 100644
--- a/libs/libarchive/Makefile
+++ b/libs/libarchive/Makefile
@@ -30,7 +30,7 @@ endef
define Package/libarchive
$(call Package/libarchive/Default)
- DEPENDS:=+libxml2 +libopenssl +zlib +libacl +libattr +libbz2 +liblzo +libnettle
+ DEPENDS:=+libopenssl +zlib
TITLE:=Multi-format archive and compression library
endef
@@ -38,6 +38,14 @@ define Package/libarchive/description
Multi-format archive and compression library.
endef
+CONFIGURE_ARGS += \
+ --disable-acl \
+ --disable-xattr \
+ --without-bz2lib \
+ --without-lzo2 \
+ --without-nettle \
+ --without-xml2
+
define Build/InstallDev
$(INSTALL_DIR) $(1)
$(CP) $(PKG_INSTALL_DIR)/* $(1)/