aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-04-06 21:33:08 -0700
committerRosen Penev <rosenp@gmail.com>2019-04-06 21:34:16 -0700
commit1266be5bc600c34f74f78c6d170dd43120205d51 (patch)
treeb16737fcc7daf6d98cb86d3a35868d4535c28320 /libs
parent85db5823208ea894cfff1229ce2a47f3e0a9842a (diff)
protobuf-c: Disable protoc for host build
On some platforms, the host build is failing as the tests fail. protoc is not used anyway. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs')
-rw-r--r--libs/protobuf-c/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/libs/protobuf-c/Makefile b/libs/protobuf-c/Makefile
index 6199766c3..e1f61e962 100644
--- a/libs/protobuf-c/Makefile
+++ b/libs/protobuf-c/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libprotobuf-c
PKG_VERSION:=1.3.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=protobuf-c-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/protobuf-c/protobuf-c/releases/download/v$(PKG_VERSION)
@@ -43,6 +43,9 @@ define Package/libprotobuf-c/description
internal RPC protocols and file formats.
endef
+HOST_CONFIGURE_ARGS += \
+ --disable-protoc
+
CONFIGURE_ARGS += \
--enable-shared \
--enable-static \