aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2021-03-19 16:26:31 -0600
committerPhilip Prindeville <philipp@redfish-solutions.com>2021-03-19 16:38:43 -0600
commit0d5c6769f15f15ce950d2b41dce3341b5c160c36 (patch)
treedc23e16fbac51f059c6428836e05950ab33e9778 /libs
parent1e0eaa1f4cce7430950497ae0a968b4db9c62e71 (diff)
treewide: fix places where $(FPIC) is unquoted
Fixes part of issue #14921. When $(FPIC) gets added to TARGET_CFLAGS (for instance), we can count on $(TARGET_CFLAGS) in turn being quoted when it gets expanded. But there are a few places where $(FPIC) gets expanded directly into environment variables passed on the command line, such as when setting lt_cv_* variables as in this case. It's wrong to assume that the expansion of $(FPIC) won't require quoting (such as it containing spaces) if it has multiple compiler flags. Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
Diffstat (limited to 'libs')
-rw-r--r--libs/libredblack/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/libs/libredblack/Makefile b/libs/libredblack/Makefile
index 2e3f020b6..5f1bcc7ea 100644
--- a/libs/libredblack/Makefile
+++ b/libs/libredblack/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libredblack
PKG_VERSION:=1.3
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/libredblack
@@ -38,7 +38,7 @@ define Package/libredblack/description
endef
CONFIGURE_ARGS += --without-rbgen
-CONFIGURE_VARS += lt_cv_prog_cc_pic=$(FPIC)
+CONFIGURE_VARS += lt_cv_prog_cc_pic="$(FPIC)"
MAKE_FLAGS += CFLAGS="$(TARGET_CFLAGS)"
define Build/InstallDev