aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2021-12-23 12:40:42 +0100
committerGitHub <noreply@github.com>2021-12-23 12:40:42 +0100
commit01473316a57fd3c883b805be0ec9c4217c1ea25e (patch)
tree2ac854a236f0aeb3cd8ec894adb546514e4e422a /libs
parent25dd0c63affd278a6be88629cc20bd3c66586ca8 (diff)
parent6c0f24d146305e247d793ec9e189d4002cc6e759 (diff)
Merge pull request #17389 from clayface/openldap
openldap: hide configurables when libopenldap is not enabled
Diffstat (limited to 'libs')
-rw-r--r--libs/openldap/Config.in44
-rw-r--r--libs/openldap/Makefile45
2 files changed, 46 insertions, 43 deletions
diff --git a/libs/openldap/Config.in b/libs/openldap/Config.in
new file mode 100644
index 000000000..a886bb5fc
--- /dev/null
+++ b/libs/openldap/Config.in
@@ -0,0 +1,44 @@
+if PACKAGE_libopenldap
+ config OPENLDAP_DEBUG
+ bool "Enable debugging information"
+ default y
+ help
+ Enable debugging information. This option must be enabled
+ for the loglevel directive to work.
+ config OPENLDAP_CRYPT
+ bool "Crypt(3) passwords support"
+ default n
+ help
+ With crypt(3) password storage scheme enabled, OpenLDAP can
+ receive and store SHA-256 and SHA-512 password hashes from
+ Samba AD-DC. If this option is disabled, synchronization of
+ passwords between Samba AD-DC (v4.5 and above) and OpenLDAP
+ requires use of cleartext passwords.
+ To enable crypt(3) password synchronization functionality:
+ 1. Re-include crypt(3) support in OpenWRT by enabling 'Include
+ crypt() support for SHA256, SHA512 and Blowfish ciphers' option
+ in "Advanced configuration options (for developers)" ->
+ "Toolchain Options".
+ 2. Provision AD-DC with 'password hash userPassword schemes'
+ option. For more information, see smb.conf manpage for details
+ on 'password hash userPassword schemes'.
+ 3. Use a script to synchronize passwords from AD-DC to
+ OpenLDAP. See samba-tool manpage for 'user syncpasswords'.
+ config OPENLDAP_MONITOR
+ bool "Enable monitor backend"
+ default n
+ help
+ Enable monitor backend to obtain information about the running
+ status of the daemon. See OpenLDAP documentation for more
+ information.
+ config OPENLDAP_DB47
+ bool "Berkeley DB support"
+ default n
+ help
+ Enable Berkeley DB support (BDB).
+ config OPENLDAP_ICU
+ bool "ICU support"
+ default n
+ help
+ Enable ICU (International Components for Unicode) support.
+endif
diff --git a/libs/openldap/Makefile b/libs/openldap/Makefile
index 2a3a456bf..cdf254d5d 100644
--- a/libs/openldap/Makefile
+++ b/libs/openldap/Makefile
@@ -55,49 +55,8 @@ define Package/libopenldap
TITLE+= (libraries)
endef
-define Package/libopenldap/config
- config OPENLDAP_DEBUG
- bool "Enable debugging information"
- default y
- help
- Enable debugging information. This option must be enabled
- for the loglevel directive to work.
- config OPENLDAP_CRYPT
- bool "Crypt(3) passwords support"
- default n
- help
- With crypt(3) password storage scheme enabled, OpenLDAP can
- receive and store SHA-256 and SHA-512 password hashes from
- Samba AD-DC. If this option is disabled, synchronization of
- passwords between Samba AD-DC (v4.5 and above) and OpenLDAP
- requires use of cleartext passwords.
- To enable crypt(3) password synchronization functionality:
- 1. Re-include crypt(3) support in OpenWRT by enabling 'Include
- crypt() support for SHA256, SHA512 and Blowfish ciphers' option
- in "Advanced configuration options (for developers)" ->
- "Toolchain Options".
- 2. Provision AD-DC with 'password hash userPassword schemes'
- option. For more information, see smb.conf manpage for details
- on 'password hash userPassword schemes'.
- 3. Use a script to synchronize passwords from AD-DC to
- OpenLDAP. See samba-tool manpage for 'user syncpasswords'.
- config OPENLDAP_MONITOR
- bool "Enable monitor backend"
- default n
- help
- Enable monitor backend to obtain information about the running
- status of the daemon. See OpenLDAP documentation for more
- information.
- config OPENLDAP_DB47
- bool "Berkeley DB support"
- default n
- help
- Enable Berkeley DB support (BDB).
- config OPENLDAP_ICU
- bool "ICU support"
- default n
- help
- Enable ICU (International Components for Unicode) support.
+define Package/openldap/config
+ source "$(SOURCE)/Config.in"
endef
define Package/libopenldap/description