aboutsummaryrefslogtreecommitdiff
path: root/libs/zmq/patches/020-no-libbsd.patch
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2024-02-14 16:41:59 -0800
committerRosen Penev <rosenp@gmail.com>2024-02-14 17:40:25 -0800
commit7536aebe63686f5533d081dbb97bc3cbe60b7063 (patch)
tree92f2437fc055b5db8c31fd6a7c477e892d138aea /libs/zmq/patches/020-no-libbsd.patch
parent8bdf5f94bdfacd79a353e72441f31610adcbf3c0 (diff)
zmq: update to 4.3.5
Remove GCC13 backport. Refresh other patches. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/zmq/patches/020-no-libbsd.patch')
-rw-r--r--libs/zmq/patches/020-no-libbsd.patch127
1 files changed, 8 insertions, 119 deletions
diff --git a/libs/zmq/patches/020-no-libbsd.patch b/libs/zmq/patches/020-no-libbsd.patch
index 0ed003945..641b69b6e 100644
--- a/libs/zmq/patches/020-no-libbsd.patch
+++ b/libs/zmq/patches/020-no-libbsd.patch
@@ -7,38 +7,13 @@ libbsd is only used once and as part of a larger, incorrect function.
I rewrote the code that used it without the need for it.
---
CMakeLists.txt | 41 ++++++-----------------------
- Makefile.am | 12 ++++-----
builds/cmake/platform.hpp.in | 2 --
- configure.ac | 39 +--------------------------
- packaging/debian/control | 2 --
- packaging/debian/zeromq.dsc | 2 +-
- packaging/redhat/zeromq.spec | 2 +-
src/compat.hpp | 51 +++++++++++++++++++++++-------------
8 files changed, 50 insertions(+), 101 deletions(-)
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -240,19 +240,6 @@ if(NOT ZMQ_USE_GNUTLS)
- endif()
- endif()
-
--if(NOT MSVC)
-- option(WITH_LIBBSD "Use libbsd instead of builtin strlcpy" ON)
-- if(WITH_LIBBSD)
-- pkg_check_modules(LIBBSD "libbsd")
-- if(LIBBSD_FOUND)
-- message(STATUS "Using libbsd")
-- set(pkg_config_names_private "${pkg_config_names_private} libbsd")
-- set(ZMQ_HAVE_LIBBSD 1)
-- endif()
-- endif()
-- check_cxx_symbol_exists(strlcpy string.h ZMQ_HAVE_STRLCPY)
--endif()
--
- # Select curve encryption library, defaults to tweetnacl To use libsodium instead, use --with-libsodium(must be
- # installed) To disable curve, use --disable-curve
-
-@@ -1437,10 +1424,6 @@ if(BUILD_SHARED)
+@@ -1484,10 +1484,6 @@ if(BUILD_SHARED)
target_link_libraries(libzmq ${NSS3_LIBRARIES})
endif()
@@ -49,8 +24,8 @@ I rewrote the code that used it without the need for it.
if(SODIUM_FOUND)
target_link_libraries(libzmq ${SODIUM_LIBRARIES})
# On Solaris, libsodium depends on libssp
-@@ -1482,10 +1465,6 @@ if(BUILD_STATIC)
- target_link_libraries(libzmq-static ${GNUTLS_LIBRARIES})
+@@ -1534,10 +1530,6 @@ if(BUILD_STATIC)
+ target_include_directories(libzmq-static PRIVATE "${GNUTLS_INCLUDE_DIR}")
endif()
- if(LIBBSD_FOUND)
@@ -60,8 +35,8 @@ I rewrote the code that used it without the need for it.
if(NSS3_FOUND)
target_link_libraries(libzmq-static ${NSS3_LIBRARIES})
endif()
-@@ -1550,10 +1529,6 @@ if(BUILD_SHARED)
- target_link_libraries(${perf-tool} ${GNUTLS_LIBRARIES})
+@@ -1607,10 +1599,6 @@ if(BUILD_SHARED)
+ target_include_directories(${perf-tool} PRIVATE "${GNUTLS_INCLUDE_DIR}")
endif()
- if(LIBBSD_FOUND)
@@ -71,40 +46,9 @@ I rewrote the code that used it without the need for it.
if(NSS3_FOUND)
target_link_libraries(${perf-tool} ${NSS3_LIBRARIES})
endif()
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -351,11 +351,11 @@ if HAVE_VSCRIPT_COMPLEX
- src_libzmq_la_LDFLAGS += $(VSCRIPT_LDFLAGS),$(srcdir)/src/libzmq.vers
- endif
-
--src_libzmq_la_CPPFLAGS = $(CODE_COVERAGE_CPPFLAGS) $(LIBUNWIND_CFLAGS) $(LIBBSD_CFLAGS)
--src_libzmq_la_CFLAGS = $(CODE_COVERAGE_CFLAGS) $(LIBUNWIND_CFLAGS) $(LIBBSD_CFLAGS)
-+src_libzmq_la_CPPFLAGS = $(CODE_COVERAGE_CPPFLAGS) $(LIBUNWIND_CFLAGS)
-+src_libzmq_la_CFLAGS = $(CODE_COVERAGE_CFLAGS) $(LIBUNWIND_CFLAGS)
- src_libzmq_la_CXXFLAGS = @LIBZMQ_EXTRA_CXXFLAGS@ $(CODE_COVERAGE_CXXFLAGS) \
-- $(LIBUNWIND_CFLAGS) $(LIBBSD_CFLAGS)
--src_libzmq_la_LIBADD = $(CODE_COVERAGE_LDFLAGS) $(LIBUNWIND_LIBS) $(LIBBSD_LIBS)
-+ $(LIBUNWIND_CFLAGS)
-+src_libzmq_la_LIBADD = $(CODE_COVERAGE_LDFLAGS) $(LIBUNWIND_LIBS)
-
- if USE_NSS
- src_libzmq_la_CPPFLAGS += ${NSS3_CFLAGS}
-@@ -849,10 +849,10 @@ tests_test_security_curve_SOURCES += \
- endif
-
- tests_test_security_curve_LDADD = \
-- ${TESTUTIL_LIBS} src/libzmq.la $(LIBUNWIND_LIBS) $(LIBBSD_LIBS)
-+ ${TESTUTIL_LIBS} src/libzmq.la $(LIBUNWIND_LIBS)
- tests_test_security_curve_CPPFLAGS = \
- ${TESTUTIL_CPPFLAGS} \
-- ${LIBUNWIND_CFLAGS} ${LIBBSD_CFLAGS}
-+ ${LIBUNWIND_CFLAGS}
-
- if USE_LIBSODIUM
- tests_test_security_curve_CPPFLAGS += \
--- a/builds/cmake/platform.hpp.in
+++ b/builds/cmake/platform.hpp.in
-@@ -52,8 +52,6 @@
+@@ -56,8 +56,6 @@
#cmakedefine ZMQ_HAVE_PTHREAD_SET_AFFINITY
#cmakedefine HAVE_ACCEPT4
#cmakedefine HAVE_STRNLEN
@@ -112,65 +56,10 @@ I rewrote the code that used it without the need for it.
-#cmakedefine ZMQ_HAVE_LIBBSD
#cmakedefine ZMQ_HAVE_IPC
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -12,7 +12,7 @@ AC_CONFIG_AUX_DIR(config)
- AC_CONFIG_MACRO_DIR(config)
- AC_CONFIG_HEADERS([src/platform.hpp])
- AM_INIT_AUTOMAKE(foreign subdir-objects tar-ustar dist-zip)
--# Allow "configure --disable-maintainer-mode" to disable timestamp checking
-+# Allow "configure --disable-maintainer-mode" to disable timestamp checking
- AM_MAINTAINER_MODE([enable])
-
- m4_pattern_allow([AC_PROG_CC_C99])
-@@ -806,43 +806,6 @@ AC_COMPILE_IFELSE(
- ],[
- AC_MSG_RESULT([no])
- ])
--
--AC_ARG_ENABLE([libbsd],
-- [AS_HELP_STRING([--enable-libbsd],
-- [enable libbsd [default=auto]])],
-- [enable_libbsd=$enableval],
-- [enable_libbsd="auto"])
--
--if test "x$enable_libbsd" != "xno"; then
-- PKG_CHECK_MODULES(LIBBSD, [libbsd],
-- [
-- AC_DEFINE(ZMQ_HAVE_LIBBSD, 1, [The libbsd library is to be used])
-- AC_SUBST([LIBBSD_CFLAGS])
-- AC_SUBST([LIBBSD_LIBS])
-- PKGCFG_NAMES_PRIVATE="$PKGCFG_NAMES_PRIVATE libbsd"
-- found_libbsd="yes"
-- ],
-- [
-- found_libbsd="no"
-- if test "x$enable_libbsd" = "xyes"; then
-- AC_MSG_ERROR([Cannot find libbsd])
-- else
-- AC_MSG_WARN([Cannot find libbsd])
-- fi
-- ])
--fi
--AC_MSG_CHECKING([whether strlcpy is available])
--AC_COMPILE_IFELSE(
-- [AC_LANG_PROGRAM(
-- [[#include <string.h>]],
-- [[char buf [100]; size_t bar = strlcpy (buf, "foo", 100); (void)bar; return 0;]])
-- ],[
-- AC_MSG_RESULT([yes])
-- AC_DEFINE(ZMQ_HAVE_STRLCPY, [1],
-- [strlcpy is available])
-- ],[
-- AC_MSG_RESULT([no])
--])
-
- # pthread_setname is non-posix, and there are at least 4 different implementations
- AC_MSG_CHECKING([whether signature of pthread_setname_np() has 1 argument])
+ #cmakedefine ZMQ_HAVE_STRUCT_SOCKADDR_UN
--- a/src/compat.hpp
+++ b/src/compat.hpp
-@@ -37,26 +37,41 @@
+@@ -10,26 +10,41 @@
#define strcasecmp _stricmp
#define strtok_r strtok_s
#else