aboutsummaryrefslogtreecommitdiff
path: root/libs/yajl/patches
diff options
context:
space:
mode:
authorCharles Southerland <charlie@stuphlabs.com>2015-07-29 09:46:58 -0500
committerCharles Southerland <charlie@stuphlabs.com>2015-07-29 09:46:58 -0500
commitf3eeede823154cccbb4757c805c7238e1714bcbb (patch)
tree4505f1abe9bd58d890aad37532d851155b1c6388 /libs/yajl/patches
parent76e84e8be9a86c28ee1d8b8dc785e60df6b1d49a (diff)
yajl: add yajl
Adds YAJL (Yet Another JSON Library), a C library for parsing JSON. Includes patches for uClibc support. Improved from version used internally at Who's On My WiFi since Feb 2014. Adds myself as maintainer. Signed-off-by: Charles Southerland <charlie@stuphlabs.com>
Diffstat (limited to 'libs/yajl/patches')
-rw-r--r--libs/yajl/patches/100-link-reformatter-uclibc-libm.patch11
-rw-r--r--libs/yajl/patches/101-link-perf-uclibc-libm.patch8
2 files changed, 19 insertions, 0 deletions
diff --git a/libs/yajl/patches/100-link-reformatter-uclibc-libm.patch b/libs/yajl/patches/100-link-reformatter-uclibc-libm.patch
new file mode 100644
index 000000000..fd637eca5
--- /dev/null
+++ b/libs/yajl/patches/100-link-reformatter-uclibc-libm.patch
@@ -0,0 +1,11 @@
+--- a/reformatter/CMakeLists.txt
++++ b/reformatter/CMakeLists.txt
+@@ -26,7 +26,7 @@
+
+ ADD_EXECUTABLE(json_reformat ${SRCS})
+
+-TARGET_LINK_LIBRARIES(json_reformat yajl_s)
++TARGET_LINK_LIBRARIES(json_reformat yajl_s m)
+
+ # copy the binary into the output directory
+ GET_TARGET_PROPERTY(binPath json_reformat LOCATION)
diff --git a/libs/yajl/patches/101-link-perf-uclibc-libm.patch b/libs/yajl/patches/101-link-perf-uclibc-libm.patch
new file mode 100644
index 000000000..0d6fd4795
--- /dev/null
+++ b/libs/yajl/patches/101-link-perf-uclibc-libm.patch
@@ -0,0 +1,8 @@
+--- a/perf/CMakeLists.txt
++++ b/perf/CMakeLists.txt
+@@ -20,4 +20,4 @@
+
+ ADD_EXECUTABLE(perftest ${SRCS})
+
+-TARGET_LINK_LIBRARIES(perftest yajl_s)
++TARGET_LINK_LIBRARIES(perftest yajl_s m)