aboutsummaryrefslogtreecommitdiff
path: root/libs/yajl/patches
diff options
context:
space:
mode:
authorIlya Lipnitskiy <ilya.lipnitskiy@gmail.com>2021-02-20 16:02:15 -0800
committerIlya Lipnitskiy <ilya.lipnitskiy@gmail.com>2021-02-20 16:02:15 -0800
commit5d8d4fbbcb5c5de9370711c19bb3510210989a98 (patch)
treed0754921833f413b7eb93fb6bb1b1c8a22fb0498 /libs/yajl/patches
parentd651082447b4392399a40ea1ae11d0bce4bfe83a (diff)
treewide: Run refresh on all packages
The crude loop I wrote to come up with this changeset: find -L package/feeds/packages/ -name patches | \ sed 's/patches$/refresh/' | sort | xargs make Signed-off-by: Ilya Lipnitskiy <ilya.lipnitskiy@gmail.com>
Diffstat (limited to 'libs/yajl/patches')
-rw-r--r--libs/yajl/patches/100-link-reformatter-uclibc-libm.patch6
-rw-r--r--libs/yajl/patches/101-link-perf-uclibc-libm.patch2
2 files changed, 4 insertions, 4 deletions
diff --git a/libs/yajl/patches/100-link-reformatter-uclibc-libm.patch b/libs/yajl/patches/100-link-reformatter-uclibc-libm.patch
index fd637eca5..21aa41f63 100644
--- a/libs/yajl/patches/100-link-reformatter-uclibc-libm.patch
+++ b/libs/yajl/patches/100-link-reformatter-uclibc-libm.patch
@@ -1,11 +1,11 @@
--- a/reformatter/CMakeLists.txt
+++ b/reformatter/CMakeLists.txt
-@@ -26,7 +26,7 @@
+@@ -26,7 +26,7 @@ LINK_DIRECTORIES(${CMAKE_CURRENT_BINARY_
ADD_EXECUTABLE(json_reformat ${SRCS})
-TARGET_LINK_LIBRARIES(json_reformat yajl_s)
+TARGET_LINK_LIBRARIES(json_reformat yajl_s m)
- # copy the binary into the output directory
- GET_TARGET_PROPERTY(binPath json_reformat LOCATION)
+ # In some environments, we must explicitly link libm (like qnx,
+ # thanks @shahbag)
diff --git a/libs/yajl/patches/101-link-perf-uclibc-libm.patch b/libs/yajl/patches/101-link-perf-uclibc-libm.patch
index 0d6fd4795..797c4a7da 100644
--- a/libs/yajl/patches/101-link-perf-uclibc-libm.patch
+++ b/libs/yajl/patches/101-link-perf-uclibc-libm.patch
@@ -1,6 +1,6 @@
--- a/perf/CMakeLists.txt
+++ b/perf/CMakeLists.txt
-@@ -20,4 +20,4 @@
+@@ -20,4 +20,4 @@ LINK_DIRECTORIES(${CMAKE_CURRENT_BINARY_
ADD_EXECUTABLE(perftest ${SRCS})