aboutsummaryrefslogtreecommitdiff
path: root/libs/vips/patches/001-no_introspection.patch
diff options
context:
space:
mode:
authorW. Michael Petullo <mike@flyn.org>2020-11-19 13:03:37 -0600
committerW. Michael Petullo <mike@flyn.org>2020-11-19 13:03:37 -0600
commit74e30ea9244749a0f13175df6e62fe0800b9ed3b (patch)
tree6b168ff341d9ac793992e60ce76999a19440ba3c /libs/vips/patches/001-no_introspection.patch
parent78dd3e05a8e4be0625bade05eb1831cb319df34c (diff)
vips: update to 8.10.2
Signed-off-by: W. Michael Petullo <mike@flyn.org>
Diffstat (limited to 'libs/vips/patches/001-no_introspection.patch')
-rw-r--r--libs/vips/patches/001-no_introspection.patch24
1 files changed, 13 insertions, 11 deletions
diff --git a/libs/vips/patches/001-no_introspection.patch b/libs/vips/patches/001-no_introspection.patch
index 8491339bd..92c67f511 100644
--- a/libs/vips/patches/001-no_introspection.patch
+++ b/libs/vips/patches/001-no_introspection.patch
@@ -1,18 +1,20 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -53,9 +53,6 @@ AC_SUBST(LIBRARY_CURRENT)
+diff -u --recursive vips-8.10.2-vanilla/configure.ac vips-8.10.2/configure.ac
+--- vips-8.10.2-vanilla/configure.ac 2020-10-12 11:43:59.000000000 -0500
++++ vips-8.10.2/configure.ac 2020-11-19 12:17:39.393295442 -0600
+@@ -53,9 +53,6 @@
AC_SUBST(LIBRARY_REVISION)
AC_SUBST(LIBRARY_AGE)
-# init introspection support
-GOBJECT_INTROSPECTION_CHECK([1.30.0])
-
- # gir needs a list of source files to scan for introspection
- #
- # build with a glob and a list of files to exclude from scanning
---- a/libvips/Makefile.am
-+++ b/libvips/Makefile.am
-@@ -68,56 +68,3 @@ install-exec-hook:
+ # remove the '(disabled, use --enable-introspection to enable)'
+ # suffix from the found_introspection variable
+ if test "x$found_introspection" != x"yes"; then
+diff -u --recursive vips-8.10.2-vanilla/libvips/Makefile.am vips-8.10.2/libvips/Makefile.am
+--- vips-8.10.2-vanilla/libvips/Makefile.am 2020-09-14 10:38:03.000000000 -0500
++++ vips-8.10.2/libvips/Makefile.am 2020-11-19 12:18:08.473384766 -0600
+@@ -67,56 +67,3 @@
echo "#define VIPS_SONAME \"$$dlname\"" >> soname.h && \
cp soname.h $(DESTDIR)$(pkgincludedir) && \
rm soname.h
@@ -35,7 +37,7 @@
-LDADD = @INTROSPECTION_LIBS@ @VIPS_CFLAGS@ libvips.la @VIPS_LIBS@
-
-noinst_PROGRAMS = \
-- introspect
+- introspect$(EXEEXT)
-introspect_SOURCES = \
- introspect.c
-
@@ -44,7 +46,7 @@
-introspection_sources = @vips_introspection_sources@
-
-# we make the vips8 API
--Vips-8.0.gir: introspect
+-Vips-8.0.gir: introspect$(EXEEXT)
-Vips_8_0_gir_INCLUDES = GObject-2.0
-Vips_8_0_gir_CFLAGS = $(INCLUDES) -I${top_srcdir}/libvips/include
-Vips_8_0_gir_LIBS = libvips.la