aboutsummaryrefslogtreecommitdiff
path: root/libs/unixodbc
diff options
context:
space:
mode:
authorEneas U de Queiroz <cote2004-github@yahoo.com>2018-12-06 12:03:02 -0200
committerEneas U de Queiroz <cote2004-github@yahoo.com>2018-12-06 12:03:02 -0200
commite4693dd939ad7901137b3b201be18a1c51d18f6c (patch)
treeabf81714a0988e5e5af9a5627749b6235c763a6b /libs/unixodbc
parent8dc012dfad6559a00f0aa78fb12a9ce8912d624c (diff)
unixodbc: fix clean-build compilation
For host compilation, the configure-generated config.h from the target compilation is used in place of the host-generated file. When the target package is compiled with clean-build, that file is gone. This saves the file under $(STAGING_DIR), and fetch it from there. Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
Diffstat (limited to 'libs/unixodbc')
-rw-r--r--libs/unixodbc/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/libs/unixodbc/Makefile b/libs/unixodbc/Makefile
index 21a8af180..fad277eac 100644
--- a/libs/unixodbc/Makefile
+++ b/libs/unixodbc/Makefile
@@ -97,6 +97,8 @@ endef
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/$(STAGING_DIR)/usr/include/*.h $(1)/usr/include/
+ # Save autoconf config.h file for host build
+ $(CP) $(PKG_BUILD_DIR)/config.h $(1)/usr/include/unixodbc_ac_config.h
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
$(INSTALL_DIR) $(1)/etc
@@ -131,7 +133,8 @@ endef
define Host/Configure
$(call Host/Configure/Default)
- cp $(PKG_BUILD_DIR)/config.h $(HOST_BUILD_DIR)
+ # copy target autoconf config.h file for host build
+ cp $(STAGING_DIR)/usr/include/unixodbc_ac_config.h $(HOST_BUILD_DIR)
sed -i -e 's!\(LIB_PREFIX \).*$$$$!\1"$(STAGING_DIR)/usr/lib"!' $(HOST_BUILD_DIR)/config.h
cp $(PKG_BUILD_DIR)/unixodbc_conf.h $(HOST_BUILD_DIR)
endef