aboutsummaryrefslogtreecommitdiff
path: root/libs/unixodbc
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-10-27 14:18:54 +0800
committerRosen Penev <rosenp@gmail.com>2023-10-30 13:25:58 -0700
commit61de50de5f787b08e06de9425ec409c8fd1ffcbf (patch)
tree8a6a8b3f3f9f21700dd84d73ee5629de2ea603d0 /libs/unixodbc
parentf3d25a747288dee52c0ca103f88882f220591e29 (diff)
unixodbc: Change host build directories to be target-specific
Since the host odbc_config returns target-specific information, it should be built and placed into target-specific locations. This changes HOST_BUILD_DIR to be in $(BUILD_DIR)/host, and installs odbc_config inside $(STAGING_DIR)/host. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'libs/unixodbc')
-rw-r--r--libs/unixodbc/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/libs/unixodbc/Makefile b/libs/unixodbc/Makefile
index bdc52e713..c99b8e4f6 100644
--- a/libs/unixodbc/Makefile
+++ b/libs/unixodbc/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=unixodbc
PKG_VERSION:=2.3.9
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=unixODBC-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.unixodbc.org
@@ -20,7 +20,7 @@ PKG_LICENSE:=prog GPL libs LGPL
PKG_CPE_ID:=cpe:/a:unixodbc:unixodbc
PKG_BUILD_DIR:=$(BUILD_DIR)/unixODBC-$(PKG_VERSION)
-HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/unixODBC-$(PKG_VERSION)
+HOST_BUILD_DIR:=$(BUILD_DIR)/host/unixODBC-$(PKG_VERSION)
HOST_BUILD_DEPENDS:=unixodbc
PKG_FIXUP:=autoreconf
@@ -150,8 +150,8 @@ define Host/Compile
endef
define Host/Install
- $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/exe/odbc_config $(STAGING_DIR_HOST)/bin
+ $(INSTALL_DIR) $(STAGING_DIR)/host/bin
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/exe/odbc_config $(STAGING_DIR)/host/bin/
endef
$(eval $(call BuildPackage,unixodbc))