aboutsummaryrefslogtreecommitdiff
path: root/libs/tiff
diff options
context:
space:
mode:
authorSebastian Kemper <sebastian_ml@gmx.net>2018-02-24 11:56:02 +0100
committerSebastian Kemper <sebastian_ml@gmx.net>2018-02-24 11:56:03 +0100
commitfad60143571b60927b52c81ffdf1869b358a9077 (patch)
tree317948977720b01b6b87086e580b79c373ecc1ac /libs/tiff
parent5b5659850dbaae4d2ac2e3f599015f71e341841e (diff)
tiff: remove $(FPIC) from TARGET_CFLAGS
tiff already makes sure that the compiler emits position-independent code. Adding $(FPIC) makes no difference. In addition the tiff build system puts its own flag behind the CFLAGS, overriding whatever was set before. Also with $(FPIC) in CFLAGS even the tiff utils get compiled with PIC, which us undesirable. Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
Diffstat (limited to 'libs/tiff')
-rw-r--r--libs/tiff/Makefile2
1 files changed, 0 insertions, 2 deletions
diff --git a/libs/tiff/Makefile b/libs/tiff/Makefile
index 1f28ab148..78d931268 100644
--- a/libs/tiff/Makefile
+++ b/libs/tiff/Makefile
@@ -58,8 +58,6 @@ $(call Package/tiff/Default)
DEPENDS:=+libtiff
endef
-TARGET_CFLAGS += $(FPIC)
-
define Build/Configure
$(call Build/Configure/Default, \
$(if $(CONFIG_PACKAGE_libtiffxx), \