aboutsummaryrefslogtreecommitdiff
path: root/libs/tdb/Makefile
diff options
context:
space:
mode:
authorEneas U de Queiroz <cote2004-github@yahoo.com>2018-05-23 14:16:09 -0300
committerEneas U de Queiroz <cote2004-github@yahoo.com>2018-05-23 14:16:09 -0300
commit75d9ab331ddcd62a91789ad93da16d7c56e55bf6 (patch)
treee534397850e181c7ab20da48b0bc91a723f247ef /libs/tdb/Makefile
parentd9e9b59159309449df7a7a6d4ab87980dc16eac2 (diff)
tdb: avoid installing duplicate files
Use $(CP) instead of $(INSTALL) so that libtdb.so.1 is installed as symlink, and not duplicated. Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
Diffstat (limited to 'libs/tdb/Makefile')
-rw-r--r--libs/tdb/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/libs/tdb/Makefile b/libs/tdb/Makefile
index db6cd056f..48a88009c 100644
--- a/libs/tdb/Makefile
+++ b/libs/tdb/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=tdb
PKG_VERSION:=1.3.15
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=GPL-2.0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -83,7 +83,7 @@ endef
define Package/tdb/install
$(INSTALL_DIR) $(1)/usr/lib
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so.* $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
endef