aboutsummaryrefslogtreecommitdiff
path: root/libs/spice
diff options
context:
space:
mode:
authorIlya Lipnitskiy <ilya.lipnitskiy@gmail.com>2021-02-20 16:02:15 -0800
committerIlya Lipnitskiy <ilya.lipnitskiy@gmail.com>2021-02-20 16:02:15 -0800
commit5d8d4fbbcb5c5de9370711c19bb3510210989a98 (patch)
treed0754921833f413b7eb93fb6bb1b1c8a22fb0498 /libs/spice
parentd651082447b4392399a40ea1ae11d0bce4bfe83a (diff)
treewide: Run refresh on all packages
The crude loop I wrote to come up with this changeset: find -L package/feeds/packages/ -name patches | \ sed 's/patches$/refresh/' | sort | xargs make Signed-off-by: Ilya Lipnitskiy <ilya.lipnitskiy@gmail.com>
Diffstat (limited to 'libs/spice')
-rw-r--r--libs/spice/patches/010-librt-libm.patch4
-rw-r--r--libs/spice/patches/020-no-code-generation.patch43
-rw-r--r--libs/spice/patches/030-include-generated-code.patch26
-rw-r--r--libs/spice/patches/040-only-server.patch4
-rw-r--r--libs/spice/patches/050-no-mkenums.patch2
5 files changed, 29 insertions, 50 deletions
diff --git a/libs/spice/patches/010-librt-libm.patch b/libs/spice/patches/010-librt-libm.patch
index 69f64913b..faba9632d 100644
--- a/libs/spice/patches/010-librt-libm.patch
+++ b/libs/spice/patches/010-librt-libm.patch
@@ -13,11 +13,9 @@ Acked-by: Frediano Ziglio <fziglio@redhat.com>
meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
-diff --git a/meson.build b/meson.build
-index 1685c077..f9090a82 100644
--- a/meson.build
+++ b/meson.build
-@@ -102,7 +102,7 @@ foreach dep : ['libjpeg', 'zlib']
+@@ -103,7 +103,7 @@ foreach dep : ['libjpeg', 'zlib']
endforeach
if host_machine.system() != 'windows'
diff --git a/libs/spice/patches/020-no-code-generation.patch b/libs/spice/patches/020-no-code-generation.patch
index ec4cd62fa..89a7eb32d 100644
--- a/libs/spice/patches/020-no-code-generation.patch
+++ b/libs/spice/patches/020-no-code-generation.patch
@@ -14,11 +14,9 @@ Signed-off-by: Frediano Ziglio <fziglio@redhat.com>
tests/meson.build | 34 ++++++++++++++++++----------------
4 files changed, 47 insertions(+), 41 deletions(-)
-diff --git a/common/meson.build b/common/meson.build
-index 7356cc0..14bf242 100644
--- a/subprojects/spice-common/common/meson.build
+++ b/subprojects/spice-common/common/meson.build
-@@ -67,19 +67,21 @@ spice_common_dep = declare_dependency(link_with : spice_common_lib,
+@@ -67,19 +67,21 @@ spice_common_dep = declare_dependency(li
# client_demarshallers
@@ -28,13 +26,6 @@ index 7356cc0..14bf242 100644
- '--include', 'common/messages.h',
- '--generated-declaration-file', '@OUTPUT1@',
- '@INPUT@', '@OUTPUT0@']
--
--client_demarshallers = custom_target('client_demarshallers',
-- input : [spice_proto],
-- output : ['generated_client_demarshallers.c', 'generated_messages.h'],
-- install : false,
-- command : [codegen_cmd, codegen_args],
-- depend_files : [spice_codegen_files, 'messages.h'])
+if spice_common_generate_client_code or spice_common_generate_server_code
+ codegen_cmd = [python, spice_codegen]
+ codegen_args = ['--generate-demarshallers',
@@ -42,7 +33,13 @@ index 7356cc0..14bf242 100644
+ '--include', 'common/messages.h',
+ '--generated-declaration-file', '@OUTPUT1@',
+ '@INPUT@', '@OUTPUT0@']
-+
+
+-client_demarshallers = custom_target('client_demarshallers',
+- input : [spice_proto],
+- output : ['generated_client_demarshallers.c', 'generated_messages.h'],
+- install : false,
+- command : [codegen_cmd, codegen_args],
+- depend_files : [spice_codegen_files, 'messages.h'])
+ client_demarshallers = custom_target('client_demarshallers',
+ input : [spice_proto],
+ output : ['generated_client_demarshallers.c', 'generated_messages.h'],
@@ -53,17 +50,18 @@ index 7356cc0..14bf242 100644
#
# libspice-common-client
-diff --git a/meson.build b/meson.build
-index 41a9419..b60a9fe 100644
--- a/subprojects/spice-common/meson.build
+++ b/subprojects/spice-common/meson.build
-@@ -119,17 +119,19 @@ foreach dep, version : optional_deps
+@@ -131,17 +131,19 @@ foreach dep, version : optional_deps
endforeach
# Python
-py_module = import('python')
-python = py_module.find_installation()
--
++if spice_common_generate_client_code or spice_common_generate_server_code
++ py_module = import('python')
++ python = py_module.find_installation()
+
-if get_option('python-checks')
- foreach module : ['six', 'pyparsing']
- message('Checking for python module @0@'.format(module))
@@ -72,10 +70,6 @@ index 41a9419..b60a9fe 100644
- error('Python module @0@ not found'.format(module))
- endif
- endforeach
-+if spice_common_generate_client_code or spice_common_generate_server_code
-+ py_module = import('python')
-+ python = py_module.find_installation()
-+
+ if get_option('python-checks')
+ foreach module : ['six', 'pyparsing']
+ message('Checking for python module @0@'.format(module))
@@ -88,11 +82,9 @@ index 41a9419..b60a9fe 100644
endif
# smartcard check
-diff --git a/meson_options.txt b/meson_options.txt
-index d30858f..d93d74b 100644
--- a/subprojects/spice-common/meson_options.txt
+++ b/subprojects/spice-common/meson_options.txt
-@@ -39,7 +39,7 @@ option('manual',
+@@ -45,7 +45,7 @@ option('manual',
option('generate-code',
type : 'combo',
@@ -101,11 +93,9 @@ index d30858f..d93d74b 100644
description : 'Which code should be built')
option('tests',
-diff --git a/tests/meson.build b/tests/meson.build
-index d315056..1ad5bc5 100644
--- a/subprojects/spice-common/tests/meson.build
+++ b/subprojects/spice-common/tests/meson.build
-@@ -20,26 +20,28 @@ endforeach
+@@ -15,26 +15,28 @@ endforeach
#
# test_marshallers
#
@@ -150,6 +140,3 @@ index d315056..1ad5bc5 100644
#
# test_quic
---
-GitLab
-
diff --git a/libs/spice/patches/030-include-generated-code.patch b/libs/spice/patches/030-include-generated-code.patch
index a6caf2707..4d8d5e37c 100644
--- a/libs/spice/patches/030-include-generated-code.patch
+++ b/libs/spice/patches/030-include-generated-code.patch
@@ -10,14 +10,18 @@ Signed-off-by: Rosen Penev <rosenp@gmail.com>
subprojects/spice-common/common/meson.build | 13 +++++++++++++
1 file changed, 13 insertions(+)
-diff --git a/subprojects/spice-common/common/meson.build b/subprojects/spice-common/common/meson.build
-index 7356cc0..5796989 100644
--- a/subprojects/spice-common/common/meson.build
+++ b/subprojects/spice-common/common/meson.build
-@@ -180,6 +180,19 @@ if spice_common_generate_server_code
- endif
- endforeach
-
+@@ -187,4 +187,17 @@ if spice_common_generate_server_code
+ spice_common_server_dep = declare_dependency(sources : spice_common_server_dep_sources,
+ link_with : spice_common_server_lib,
+ dependencies : spice_common_dep)
++else
++ spice_common_server_sources = ['generated_server_marshallers.c', 'generated_server_marshallers.h']
++ spice_common_server_sources += ['generated_server_demarshallers.c']
++ spice_common_server_dep_sources = ['generated_server_marshallers.c', 'generated_server_marshallers.h']
++ spice_common_server_dep_sources += ['generated_server_demarshallers.c']
++
+ spice_common_server_lib = static_library('spice-common-server', spice_common_server_sources,
+ install : false,
+ dependencies : spice_common_dep)
@@ -25,12 +29,4 @@ index 7356cc0..5796989 100644
+ spice_common_server_dep = declare_dependency(sources : spice_common_server_dep_sources,
+ link_with : spice_common_server_lib,
+ dependencies : spice_common_dep)
-+else
-+ spice_common_server_sources = ['generated_server_marshallers.c', 'generated_server_marshallers.h']
-+ spice_common_server_sources += ['generated_server_demarshallers.c']
-+ spice_common_server_dep_sources = ['generated_server_marshallers.c', 'generated_server_marshallers.h']
-+ spice_common_server_dep_sources += ['generated_server_demarshallers.c']
-+
- spice_common_server_lib = static_library('spice-common-server', spice_common_server_sources,
- install : false,
- dependencies : spice_common_dep)
+ endif
diff --git a/libs/spice/patches/040-only-server.patch b/libs/spice/patches/040-only-server.patch
index dd2076fe4..2c441806d 100644
--- a/libs/spice/patches/040-only-server.patch
+++ b/libs/spice/patches/040-only-server.patch
@@ -1,6 +1,6 @@
--- a/meson.build
+++ b/meson.build
-@@ -192,8 +192,6 @@ add_project_arguments(compiler.get_supported_arguments(spice_server_global_cflag
+@@ -192,8 +192,6 @@ add_project_arguments(compiler.get_suppo
# Subdirectories
#
subdir('server')
@@ -11,7 +11,7 @@
# write config.h
--- a/server/meson.build
+++ b/server/meson.build
-@@ -186,5 +186,3 @@ spice_server_libs = both_libraries('spice-server', spice_server_sources,
+@@ -186,5 +186,3 @@ spice_server_libs = both_libraries('spic
spice_server_shared_lib = spice_server_libs.get_shared_lib()
spice_server_static_lib = spice_server_libs.get_static_lib()
diff --git a/libs/spice/patches/050-no-mkenums.patch b/libs/spice/patches/050-no-mkenums.patch
index 23cd486d2..3c2b69fbb 100644
--- a/libs/spice/patches/050-no-mkenums.patch
+++ b/libs/spice/patches/050-no-mkenums.patch
@@ -10,8 +10,6 @@ Signed-off-by: Rosen Penev <rosenp@gmail.com>
server/meson.build | 6 +-----
1 file changed, 1 insertion(+), 5 deletions(-)
-diff --git a/server/meson.build b/server/meson.build
-index b2eb410..b79b8d9 100644
--- a/server/meson.build
+++ b/server/meson.build
@@ -36,11 +36,7 @@ spice_server_headers = [