aboutsummaryrefslogtreecommitdiff
path: root/libs/spice/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-04-03 19:58:40 -0700
committerYousong Zhou <yszhou4tech@gmail.com>2021-05-31 15:26:36 +0800
commite3d4d253b4fa9810a5436e017ef43db9444a16f3 (patch)
tree4b747a2574e8ead93f41f2fe3e8202f805ff3e77 /libs/spice/Makefile
parent84e27e3af74c765502835799c4a9f597ae51d15a (diff)
spice: update to 0.15.0
Remove celt051 option as upstream removed it. Remove upstreamed patches. Switch to AUTORELEASE for simplicity. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/spice/Makefile')
-rw-r--r--libs/spice/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/libs/spice/Makefile b/libs/spice/Makefile
index 55d08d6b8..e386e1e03 100644
--- a/libs/spice/Makefile
+++ b/libs/spice/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=spice
-PKG_VERSION:=0.14.3
-PKG_RELEASE:=3
+PKG_VERSION:=0.15.0
+PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://www.spice-space.org/download/releases/spice-server
-PKG_HASH:=551d4be4a07667cf0543f3c895beb6da8a93ef5a9829f2ae47817be5e616a114
+PKG_HASH:=b320cf8f4bd2852750acb703c15b72856027e5a8554f8217dfbb3cc09deba0f5
PKG_MAINTAINER:=Yousong Zhou <yszhou4tech@gmail.com>
PKG_LICENSE:=LGPL-2.1-only
@@ -31,13 +31,12 @@ define Package/libspice-server
CATEGORY:=Libraries
TITLE:=SPICE server library
URL:=https://www.spice-space.org/index.html
- DEPENDS:=+glib2 +libjpeg +libopenssl +pixman +zlib
+ DEPENDS:=+glib2 +libjpeg +libopenssl +pixman +zlib +libstdcpp
endef
# audio codec
MESON_ARGS += \
- -Dcelt051=disabled \
- -Dopus=disabled \
+ -Dopus=disabled
MESON_ARGS += \
-Dgstreamer=no \
@@ -49,11 +48,11 @@ MESON_ARGS += \
-Dstatistics=false \
-Dmanual=false \
-Dinstrumentation=no \
+ -Dtests=false
MESON_ARGS += \
-Dspice-common:alignment-checks=false \
-Dspice-common:extra-checks=false \
- -Dspice-common:celt051=disabled \
-Dspice-common:opus=disabled \
-Dspice-common:instrumentation=no \
-Dspice-common:smartcard=disabled \