aboutsummaryrefslogtreecommitdiff
path: root/libs/speexdsp/Makefile
diff options
context:
space:
mode:
authorSebastian Kemper <sebastian_ml@gmx.net>2017-07-30 10:08:52 +0200
committerSebastian Kemper <sebastian_ml@gmx.net>2017-07-30 10:08:59 +0200
commit57b8233b579a74ee35b48279dff643873b3c6c42 (patch)
treeacc10419eb4a6d3488388329743846d790849d9e /libs/speexdsp/Makefile
parent6e326f837d3d1dc2f299d9281b8bf30e7395e979 (diff)
libs/speex: version bump and refactoring
- speexdsp has been broken out of the speex package by upstream. The released versions of both aren't aligned (speex is at 1.2.0, speexdsp at 1.2rc3). Break out speexdsp into its own Makefile accordingly. - Don't disable VBR anymore as it has its applications (i.e. can be used with freeswitch-stable). - Prevent build system from changing our CFLAGS (--enable-sse=no). - Make integer mode depend on SOFT_FLOAT symbol so it doesn't get enabled on devices with FPUs. - Use PKG_INSTALL and remove custom Build/Compile as there is no need for this. Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
Diffstat (limited to 'libs/speexdsp/Makefile')
-rw-r--r--libs/speexdsp/Makefile66
1 files changed, 66 insertions, 0 deletions
diff --git a/libs/speexdsp/Makefile b/libs/speexdsp/Makefile
new file mode 100644
index 000000000..508c8789b
--- /dev/null
+++ b/libs/speexdsp/Makefile
@@ -0,0 +1,66 @@
+#
+# Copyright (C) 2006-2017 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=speexdsp
+PKG_VERSION:=1.2rc3
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://downloads.us.xiph.org/releases/speex/
+PKG_HASH:=4ae688600039f5d224bdf2e222d2fbde65608447e4c2f681585e4dca6df692f1
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libspeexdsp
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=Open source speech compression codec library output to DSP
+ URL:=http://www.speex.org/
+ MAINTAINER:=Peter Wagner <tripolar@gmx.at>
+endef
+
+define Package/libspeexdsp/description
+ Open source patent-free speech compression codec library.
+ Speex is an Open Source/Free Software patent-free audio compression
+ format designed for speech. The Speex Project aims to lower the
+ barrier of entry for voice applications by providing a free
+ alternative to expensive proprietary speech codecs. Moreover, Speex
+ is well-adapted to Internet applications and provides useful features
+ that are not present in most other codecs.
+
+ This package contains the shared dsp library, needed by other programs.
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/speex $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libspeexdsp.{a,so*} $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/speexdsp.pc $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libspeexdsp/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libspeexdsp.so.* $(1)/usr/lib/
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+CONFIGURE_ARGS += \
+ --enable-shared \
+ --enable-static \
+ --disable-examples \
+ --enable-sse=no \
+ $(if $(CONFIG_SOFT_FLOAT),--enable-fixed-point --disable-float-api)
+
+$(eval $(call BuildPackage,libspeexdsp))