aboutsummaryrefslogtreecommitdiff
path: root/libs/speex
diff options
context:
space:
mode:
authorSebastian Kemper <sebastian_ml@gmx.net>2017-07-30 17:41:07 +0200
committerSebastian Kemper <sebastian_ml@gmx.net>2017-07-30 17:51:43 +0200
commit6890d65ebd61072bb43775115a3bea53364ae711 (patch)
tree4df3211e5558f5954be1649976f58bfdffc797dc /libs/speex
parentc1faf78ed48dd9cb43653b1e96b34a0e96c04caf (diff)
libs/speex and libs/speexdsp: fix configure params
- Remove ogg params from speex configure as it doesn't know about them. - Remove --enable-sse=no from both speex and speexdsp. The configure scripts do actually not add items to our CFLAGS like previously assumed. - When --disable-float-api is used VBR needs to be disabled as well, as VBR has not been implemented with fixed-point math in speex (yet). So add --disable-vbr when --disable-float-api is used. - In speexdsp 1.2rc2 optimizations for NEON were added. Unfortunately the ASM does not work for 64bit ARM. So force NEON optimizations off when compiling for AARCH64. Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
Diffstat (limited to 'libs/speex')
-rw-r--r--libs/speex/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/libs/speex/Makefile b/libs/speex/Makefile
index 60575854f..01538ebe1 100644
--- a/libs/speex/Makefile
+++ b/libs/speex/Makefile
@@ -60,9 +60,6 @@ CONFIGURE_ARGS += \
--enable-shared \
--enable-static \
--disable-binaries \
- --disable-oggtest \
- --enable-sse=no \
- --with-ogg=$(STAGING_DIR)/usr \
- $(if $(CONFIG_SOFT_FLOAT),--enable-fixed-point --disable-float-api)
+ $(if $(CONFIG_SOFT_FLOAT),--enable-fixed-point --disable-float-api --disable-vbr)
$(eval $(call BuildPackage,libspeex))