aboutsummaryrefslogtreecommitdiff
path: root/libs/serdisplib
diff options
context:
space:
mode:
authorSergey V. Lobanov <sergey@lobanov.in>2022-01-12 16:25:40 +0300
committerDaniel Golle <daniel@makrotopia.org>2022-01-12 18:51:51 +0000
commitd504cb206fdb49b64880ec9a9fc6c71ed92a4025 (patch)
tree560d3f927af9713383dc4225faa9fe552d823049 /libs/serdisplib
parent53503c4a3a6660a67e88a37876a87e9b824ee03c (diff)
serdisplib: fix build on macos
./configure script detects if serdisplib is built on non-linux build host and disables framebuffer driver. It blocks touchscreen_tool compilation. This detection is not required on cross-compile build so it is disabled via ac_cv_build=$(GNU_TARGET_NAME) in Makefile Signed-off-by: Sergey V. Lobanov <sergey@lobanov.in>
Diffstat (limited to 'libs/serdisplib')
-rw-r--r--libs/serdisplib/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/libs/serdisplib/Makefile b/libs/serdisplib/Makefile
index 07978d01a..8b36a4a51 100644
--- a/libs/serdisplib/Makefile
+++ b/libs/serdisplib/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=serdisplib
PKG_VERSION:=2.02
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/serdisplib
@@ -51,6 +51,9 @@ define Package/serdisplib-tools/description
* touchscreen_tool
endef
+CONFIGURE_VARS += \
+ ac_cv_build=$(GNU_TARGET_NAME)
+
CONFIGURE_ARGS += \
--enable-dynloading \
--disable-statictools