aboutsummaryrefslogtreecommitdiff
path: root/libs/rxtx/Makefile
diff options
context:
space:
mode:
authorDana Myers <k6jq@comcast.net>2016-12-19 16:43:14 -0800
committerYousong Zhou <yszhou4tech@gmail.com>2016-12-19 19:50:00 -0600
commit84b163ac770d4794281682d7b8b2a63402f61e47 (patch)
tree13e294038450f752af1ffefb2ec7d915387b85d5 /libs/rxtx/Makefile
parent828cee724e8087401db7298b72438b3d762df667 (diff)
libs/rxtx: add support for RX/TX Java serial communications
Integrate support for RX/TX Java serial communications library. Includes patch to include support for ttyACM* devices. Signed-off-by: Dana H. Myers k6jq@comcast.net
Diffstat (limited to 'libs/rxtx/Makefile')
-rwxr-xr-xlibs/rxtx/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/libs/rxtx/Makefile b/libs/rxtx/Makefile
new file mode 100755
index 000000000..5a1374f4b
--- /dev/null
+++ b/libs/rxtx/Makefile
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2016 Dana H. Myers <k6jq@comcast.net>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=rxtx
+PKG_VERSION:=2.2pre2
+PKG_RELEASE:=1
+PKG_LICENSE:=LGPL-2.1
+PKG_MAINTAINER:=Dana H. Myers <k6jq@comcast.net>
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
+PKG_SOURCE_URL:=http://rxtx.qbang.org/pub/rxtx/
+PKG_MD5SUM:=7eedb18e3f33a427e2b0e9be8ce3f94c
+
+PKG_FIXUP:=patch-libtool
+PKG_CHECK_FORMAT_SECURITY:=0
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/rxtx
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=RX/TX Support for Java serial communications
+ URL:=http://rxtx.qbang.org/wiki/index.php/Main_Page
+ DEPENDS:=+libpthread
+endef
+
+define Package/rxtx/description
+ RX/TX Support for Java serial communications
+endef
+
+CONFIGURE_ARGS += \
+ --disable-PRINTER
+
+define Package/rxtx/install
+ $(INSTALL_DIR) \
+ $(1)/usr/lib/classpath
+ $(CP) $(PKG_BUILD_DIR)/$(GNU_TARGET_NAME)-gnu/.libs/*.so \
+ $(1)/usr/lib/classpath/
+ $(CP) $(PKG_BUILD_DIR)/RXTXcomm.jar \
+ $(1)/usr/lib/classpath/
+endef
+
+$(eval $(call BuildPackage,rxtx))