aboutsummaryrefslogtreecommitdiff
path: root/libs/qrencode
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-03-23 09:27:01 +0100
committerAndre Heider <a.heider@gmail.com>2023-04-08 08:38:54 +0200
commite7d9c865036d7bc2ac30604e8573f25ae601aed1 (patch)
tree5efb8a25df387e8e79356447c648ecc3306176b3 /libs/qrencode
parent35f4ef76e0c88b690ec55f26aed072c4c5989eff (diff)
treewide: refactor to use PKG_BUILD_FLAGS:=lto
See commit 07730ff3 "treewide: add support for "lto" in PKG_BUILD_FLAGS" on the main repository. Note: Some packages only added `-flto` to CFLAGS and not LDFLAGS. This fixes it and properly enables LTO. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'libs/qrencode')
-rw-r--r--libs/qrencode/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/libs/qrencode/Makefile b/libs/qrencode/Makefile
index 841128480..ee1f925b1 100644
--- a/libs/qrencode/Makefile
+++ b/libs/qrencode/Makefile
@@ -21,6 +21,8 @@ PKG_LICENSE_FILES:=COPYING
PKG_CONFIG_DEPENDS:=CONFIG_PACKAGE_qrencode
+PKG_BUILD_FLAGS:=lto
+
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
@@ -60,7 +62,6 @@ CMAKE_OPTIONS += \
-DWITH_TESTS=OFF \
-DBUILD_SHARED_LIBS=ON
-TARGET_CFLAGS += -flto
TARGET_LDFLAGS += -Wl,--gc-sections
define Build/InstallDev