aboutsummaryrefslogtreecommitdiff
path: root/libs/qrencode/Makefile
diff options
context:
space:
mode:
authorJonathan Bennett <JBennett@incomsystems.biz>2017-10-16 11:35:34 -0500
committerJonathan Bennett <JBennett@incomsystems.biz>2017-10-16 12:08:10 -0500
commit14af50642c9e3b3f8c1e2f8901667dfc95c4d93e (patch)
tree4fb1b4872058f116dccdd5d28b31a3a611371ffb /libs/qrencode/Makefile
parentdf72a84986b08bca33d7a3be79c10a9de70f5173 (diff)
qrencode: Update to 4.0.0
Adds a minor patch to optionally omit the XML tag when including svg inline. Singed-off-by: Jonathan Bennett <JBennett@Incomsystems.biz>
Diffstat (limited to 'libs/qrencode/Makefile')
-rw-r--r--libs/qrencode/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/libs/qrencode/Makefile b/libs/qrencode/Makefile
index 95a353cd4..a6a4e2f25 100644
--- a/libs/qrencode/Makefile
+++ b/libs/qrencode/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2017 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=qrencode
-PKG_VERSION:=3.4.4
-PKG_RELEASE:=2
+PKG_VERSION:=4.0.0
+PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://fukuchi.org/works/qrencode/
-PKG_HASH:=e794e26a96019013c0e3665cb06b18992668f352c5553d0a553f5d144f7f2a72
+PKG_HASH:=c90035e16921117d4086a7fdee65aab85be32beb4a376f6b664b8a425d327d0b
PKG_MAINTAINER:=Jonathan Bennett <JBennett@incomsystems.biz>
PKG_LICENSE:=LGPL-2.1+
PKG_INSTALL:=1
@@ -56,7 +56,8 @@ CONFIGURE_ARGS+= \
--enable-static \
--disable-rpath \
--disable-sdltest \
- --without-tests
+ --without-tests \
+ --without-png
TARGET_LDFLAGS+= -s