aboutsummaryrefslogtreecommitdiff
path: root/libs/pthsem
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-07-01 11:19:50 -0700
committerRosen Penev <rosenp@gmail.com>2019-07-01 11:19:50 -0700
commit145e9942e21544db341019430e48104a0abc13cc (patch)
treec372b9c004b10ba3ce4cf864e7203ff0873c8ca7 /libs/pthsem
parent8897ea4d51a660aca141036f1879c2e234797a4f (diff)
pthsem: Fix compilation with uClibc-ng
Makefile cleanups for consistency between packages. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/pthsem')
-rw-r--r--libs/pthsem/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/libs/pthsem/Makefile b/libs/pthsem/Makefile
index 9ab8a09f6..5ce4f53d6 100644
--- a/libs/pthsem/Makefile
+++ b/libs/pthsem/Makefile
@@ -9,16 +9,16 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=pthsem
PKG_VERSION:=2.0.8
-PKG_RELEASE:=5
-
-PKG_MAINTAINER:=Othmar Truniger <github@truniger.ch>
-PKG_LICENSE:=LGPL-2.1+
-PKG_LICENSE_FILES:=COPYING
+PKG_RELEASE:=6
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.auto.tuwien.ac.at/~mkoegler/pth/
PKG_HASH:=4024cafdd5d4bce2b1778a6be5491222c3f6e7ef1e43971264c451c0012c5c01
+PKG_MAINTAINER:=Othmar Truniger <github@truniger.ch>
+PKG_LICENSE:=LGPL-2.1-or-later
+PKG_LICENSE_FILES:=COPYING
+
PKG_FIXUP:=autoreconf
PKG_BUILD_PARALLEL:=1
PKG_FORTIFY_SOURCE:=0
@@ -40,7 +40,7 @@ endef
# The musl libc provides a proper implementation of sigaltstack() so
# prevent configure from wrongly assuming a broken Linux platform
-ifeq ($(CONFIG_USE_MUSL),y)
+ifneq ($(CONFIG_USE_GLIBC),y)
CONFIGURE_VARS += \
ac_cv_check_sjlj=ssjlj
endif