aboutsummaryrefslogtreecommitdiff
path: root/libs/protobuf
diff options
context:
space:
mode:
authorKen Keys <kkeys@caida.org>2018-05-23 16:37:35 -0700
committerKen Keys <kkeys@caida.org>2018-05-23 16:37:35 -0700
commitd078dbed7b1843b8510a4bec64959cfe6c294250 (patch)
tree37d9f3cd74d70b6a19d0e8a400157483d4f88961 /libs/protobuf
parentd9f3f92c390c19e46627427c2ac178359965999c (diff)
protobuf: add smaller protobuf-lite package variant
Signed-off-by: Ken Keys <kkeys@caida.org>
Diffstat (limited to 'libs/protobuf')
-rw-r--r--libs/protobuf/Makefile48
1 files changed, 39 insertions, 9 deletions
diff --git a/libs/protobuf/Makefile b/libs/protobuf/Makefile
index 2f25156bf..5b65dabd7 100644
--- a/libs/protobuf/Makefile
+++ b/libs/protobuf/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=protobuf
PKG_VERSION:=3.3.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-cpp-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/google/protobuf/releases/download/v$(PKG_VERSION)
@@ -26,19 +26,43 @@ PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/host-build.mk
-define Package/protobuf
+define Package/protobuf/Default
SECTION:=libs
CATEGORY:=Libraries
TITLE:=A structured data encoding library
URL:=https://github.com/google/protobuf
DEPENDS:=+zlib +libpthread +libstdcpp
- MAINTAINER:=Per Sandström <per.j.sandstrom@gmail.com>
+ MAINTAINER:=Ken Keys <kkeys@caida.org>
+endef
+
+define Package/protobuf
+ $(call Package/protobuf/Default)
+ DEPENDS+=+protobuf-lite
+endef
+
+define Package/protobuf-lite
+ $(call Package/protobuf/Default)
+endef
+
+define Package/protobuf/description/Default
+Protocol Buffers are a way of encoding structured data in an efficient
+yet extensible format. Google uses Protocol Buffers for almost all
+of its internal RPC protocols and file formats.
endef
define Package/protobuf/description
- Protocol Buffers are a way of encoding structured data in an efficient
- yet extensible format. Google uses Protocol Buffers for almost all
- of its internal RPC protocols and file formats.
+$(call Package/protobuf/description/Default)
+
+This package provides the libprotoc, libprotobuf, and libprotobuf-lite
+libraries. For a much smaller protobuf package, see "protobuf-lite".
+
+endef
+
+define Package/protobuf-lite/description
+$(call Package/protobuf/description/Default)
+
+This package provides the libprotobuf-lite library.
+
endef
CONFIGURE_ARGS += --with-protoc=$(STAGING_DIR_HOSTPKG)/bin/protoc
@@ -57,16 +81,21 @@ define Build/InstallDev
$(1)/usr/lib/
endef
-define Package/protobuf/install
+define Package/protobuf-lite/install
$(INSTALL_DIR) \
$(1)/usr/lib
$(CP) \
- $(PKG_INSTALL_DIR)/usr/lib/libprotoc.so* \
+ $(PKG_INSTALL_DIR)/usr/lib/libprotobuf-lite.so* \
$(1)/usr/lib/
+endef
+
+define Package/protobuf/install
+ $(INSTALL_DIR) \
+ $(1)/usr/lib
$(CP) \
- $(PKG_INSTALL_DIR)/usr/lib/libprotobuf-lite.so* \
+ $(PKG_INSTALL_DIR)/usr/lib/libprotoc.so* \
$(1)/usr/lib/
$(CP) \
@@ -75,4 +104,5 @@ define Package/protobuf/install
endef
$(eval $(call BuildPackage,protobuf))
+$(eval $(call BuildPackage,protobuf-lite))
$(eval $(call HostBuild))