aboutsummaryrefslogtreecommitdiff
path: root/libs/protobuf/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-09-21 13:24:13 -0700
committerRosen Penev <rosenp@gmail.com>2019-09-23 14:56:18 -0700
commite8da6d929451acbdcd94ae1fc747c876a84df8bc (patch)
tree3d6c217c7e6d29290b1519dc79a2461d944c7e2d /libs/protobuf/Makefile
parenta54c065ee220e33507d0f49f65b53beec0b4d7e3 (diff)
protobuf: Fix host build
rpath is needed as the host directory instead of hostpkg is used for some reason. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/protobuf/Makefile')
-rw-r--r--libs/protobuf/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/libs/protobuf/Makefile b/libs/protobuf/Makefile
index fb2d84fdd..a4310b4f5 100644
--- a/libs/protobuf/Makefile
+++ b/libs/protobuf/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=protobuf
PKG_VERSION:=3.8.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-cpp-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/google/protobuf/releases/download/v$(PKG_VERSION)
@@ -68,7 +68,10 @@ endef
CMAKE_HOST_OPTIONS += \
-Dprotobuf_BUILD_PROTOC_BINARIES=ON \
- -Dprotobuf_BUILD_TESTS=OFF
+ -Dprotobuf_BUILD_TESTS=OFF \
+ -DBUILD_SHARED_LIBS=ON \
+ -DCMAKE_SKIP_RPATH=OFF \
+ -DCMAKE_INSTALL_RPATH="${STAGING_DIR_HOSTPKG}/lib"
CMAKE_OPTIONS += \
-Dprotobuf_BUILD_PROTOC_BINARIES=ON \