aboutsummaryrefslogtreecommitdiff
path: root/libs/protobuf-c
diff options
context:
space:
mode:
authorJacob Siverskog <jacob@teenageengineering.com>2014-07-14 15:57:06 +0200
committerJacob Siverskog <jacob@teenageengineering.com>2014-07-14 15:57:06 +0200
commit97eac718c0280f2eaa8e4ba13265c143a692af6e (patch)
tree0cb3cf5b8bdf423b8df7d84dd61d46e9444a704f /libs/protobuf-c
parent207073f69419e66807e09adedf5f4f0e4f225576 (diff)
protobuf-c: import from packages, bump version.
Signed-off-by: Jacob Siverskog <jacob@teenageengineering.com>
Diffstat (limited to 'libs/protobuf-c')
-rw-r--r--libs/protobuf-c/Makefile62
1 files changed, 62 insertions, 0 deletions
diff --git a/libs/protobuf-c/Makefile b/libs/protobuf-c/Makefile
new file mode 100644
index 000000000..4a28557c7
--- /dev/null
+++ b/libs/protobuf-c/Makefile
@@ -0,0 +1,62 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libprotobuf-c
+PKG_VERSION:=2014-06-30
+PKG_RELEASE:=$(PKG_SOURCE_VERSION)
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=git://github.com/protobuf-c/protobuf-c.git
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_VERSION:=6136f54b221ab8883731349d01f34b01812e391d
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libprotobuf-c
+ TITLE:=Protocol Buffers library
+ SECTION:=libs
+ CATEGORY:=Libraries
+ URL:=http://code.google.com/p/protobuf-c/
+endef
+
+define Package/libprotobuf-c/description
+ Runtime library to use Google Protocol Buffers from C applications.
+ Protocol Buffers are a way of encoding structured data in an efficient yet
+ extensible format. Google uses Protocol Buffers for almost all of its
+ internal RPC protocols and file formats.
+endef
+
+CONFIGURE_ARGS += \
+ --enable-shared \
+ --enable-static \
+ --disable-protoc
+
+define Build/Configure
+ cd $(PKG_BUILD_DIR) && ./autogen.sh
+ $(call Build/Configure/Default)
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include/
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libprotobuf-c.{a,la,so*} $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libprotobuf-c/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libprotobuf-c.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libprotobuf-c))