aboutsummaryrefslogtreecommitdiff
path: root/libs/protobuf-c
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-06-30 17:59:28 -0700
committerRosen Penev <rosenp@gmail.com>2019-06-30 18:04:18 -0700
commit753553980d07ae5853eea22124122d88ebe4e4b9 (patch)
tree9f1b544d776395c1d4a62c3301a39fe43cd6918f /libs/protobuf-c
parentc92ef2188646324d4b7bf36589aada72f0c38543 (diff)
libprotobuf-c: Update to 1.32
Remove upstreamed patch. Updated License information. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/protobuf-c')
-rw-r--r--libs/protobuf-c/Makefile9
-rw-r--r--libs/protobuf-c/patches/001-t-generated-code2-cxx-generate-packed-data-fix.patch13
2 files changed, 5 insertions, 17 deletions
diff --git a/libs/protobuf-c/Makefile b/libs/protobuf-c/Makefile
index e04483318..e882253c7 100644
--- a/libs/protobuf-c/Makefile
+++ b/libs/protobuf-c/Makefile
@@ -8,17 +8,18 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libprotobuf-c
-PKG_VERSION:=1.3.1
-PKG_RELEASE:=2
+PKG_VERSION:=1.3.2
+PKG_RELEASE:=1
PKG_SOURCE:=protobuf-c-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/protobuf-c/protobuf-c/releases/download/v$(PKG_VERSION)
-PKG_HASH:=51472d3a191d6d7b425e32b612e477c06f73fe23e07f6a6a839b11808e9d2267
+PKG_HASH:=53f251f14c597bdb087aecf0b63630f434d73f5a10fc1ac545073597535b9e74
PKG_BUILD_DIR:=$(BUILD_DIR)/protobuf-c-$(PKG_VERSION)
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/protobuf-c-$(PKG_VERSION)
PKG_MAINTAINER:=Rosen Penev <rosenp@gmail.com>
-PKG_LICENSE:=BSD-2c
+PKG_LICENSE:=BSD-2-Clause
+PKG_LICENSE_FILES:=LICENSE
PKG_BUILD_DEPENDS:=protobuf-c/host
HOST_BUILD_DEPENDS:=protobuf/host
diff --git a/libs/protobuf-c/patches/001-t-generated-code2-cxx-generate-packed-data-fix.patch b/libs/protobuf-c/patches/001-t-generated-code2-cxx-generate-packed-data-fix.patch
deleted file mode 100644
index 2d83cec59..000000000
--- a/libs/protobuf-c/patches/001-t-generated-code2-cxx-generate-packed-data-fix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: protobuf-c-1.3.1/t/generated-code2/cxx-generate-packed-data.cc
-===================================================================
---- protobuf-c-1.3.1.orig/t/generated-code2/cxx-generate-packed-data.cc
-+++ protobuf-c-1.3.1/t/generated-code2/cxx-generate-packed-data.cc
-@@ -998,7 +998,7 @@ static void dump_test_packed_repeated_en
- static void dump_test_unknown_fields (void)
- {
- EmptyMess mess;
-- const google::protobuf::Message::Reflection *reflection = mess.GetReflection();
-+ const google::protobuf::Reflection *reflection = mess.GetReflection();
- google::protobuf::UnknownFieldSet *fs = reflection->MutableUnknownFields(&mess);
-
- #if GOOGLE_PROTOBUF_VERSION >= 2001000