aboutsummaryrefslogtreecommitdiff
path: root/libs/protobuf-c
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-09-21 13:25:21 -0700
committerRosen Penev <rosenp@gmail.com>2019-09-23 15:01:02 -0700
commit53b9d894fb4f12acfc72e6993523727f2080facd (patch)
tree4412efddca4a266451269aff5ea1ff235c8982c5 /libs/protobuf-c
parente8da6d929451acbdcd94ae1fc747c876a84df8bc (diff)
libprotobuf-c: Switch to CMake
Simplifies the Makefile. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/protobuf-c')
-rw-r--r--libs/protobuf-c/Makefile22
1 files changed, 6 insertions, 16 deletions
diff --git a/libs/protobuf-c/Makefile b/libs/protobuf-c/Makefile
index e882253c7..d019b4cdc 100644
--- a/libs/protobuf-c/Makefile
+++ b/libs/protobuf-c/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libprotobuf-c
PKG_VERSION:=1.3.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=protobuf-c-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/protobuf-c/protobuf-c/releases/download/v$(PKG_VERSION)
@@ -21,11 +21,12 @@ PKG_MAINTAINER:=Rosen Penev <rosenp@gmail.com>
PKG_LICENSE:=BSD-2-Clause
PKG_LICENSE_FILES:=LICENSE
-PKG_BUILD_DEPENDS:=protobuf-c/host
HOST_BUILD_DEPENDS:=protobuf/host
+PKG_BUILD_DEPENDS:=protobuf
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
+CMAKE_SOURCE_SUBDIR:=build-cmake
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/host-build.mk
@@ -44,23 +45,12 @@ define Package/libprotobuf-c/description
internal RPC protocols and file formats.
endef
-CONFIGURE_ARGS += \
- --enable-shared \
- --enable-static \
- --disable-protoc
-
-define Build/InstallDev
- $(INSTALL_DIR) $(1)/usr/include/
- $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
- $(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libprotobuf-c.{a,la,so*} $(1)/usr/lib/
- $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* $(1)/usr/lib/pkgconfig/
-endef
+CMAKE_OPTIONS += \
+ -DBUILD_SHARED_LIBS=ON
define Package/libprotobuf-c/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libprotobuf-c.so.* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libprotobuf-c.so* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,libprotobuf-c))