aboutsummaryrefslogtreecommitdiff
path: root/libs/postgresql/patches
diff options
context:
space:
mode:
authorDirk Neukirchen <dirkneukirchen@web.de>2015-05-22 18:17:47 +0200
committerDaniel Golle <daniel@makrotopia.org>2015-08-12 17:30:20 +0200
commit6ae54e40750c535bbec86e278645dbd1450056a0 (patch)
tree5aacb952891cb18c86fd63c3ccb5a374df9b2842 /libs/postgresql/patches
parent8511e62ff0ee88665e2269140462e95560afe076 (diff)
postgresql: update to 9.4.1
- supports arm64/aarch64 Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
Diffstat (limited to 'libs/postgresql/patches')
-rw-r--r--libs/postgresql/patches/001-configure_fixes.patch11
-rw-r--r--libs/postgresql/patches/200-ranlib.patch4
-rw-r--r--libs/postgresql/patches/800-busybox-default-pager.patch2
3 files changed, 14 insertions, 3 deletions
diff --git a/libs/postgresql/patches/001-configure_fixes.patch b/libs/postgresql/patches/001-configure_fixes.patch
new file mode 100644
index 000000000..2edaba6a0
--- /dev/null
+++ b/libs/postgresql/patches/001-configure_fixes.patch
@@ -0,0 +1,11 @@
+--- a/configure.in
++++ b/configure.in
+@@ -25,7 +25,7 @@ recommended. You can remove the check f
+ your responsibility whether the result works or not.])])
+ AC_COPYRIGHT([Copyright (c) 1996-2014, PostgreSQL Global Development Group])
+ AC_CONFIG_SRCDIR([src/backend/access/common/heaptuple.c])
+-AC_CONFIG_AUX_DIR(config)
++AC_CONFIG_AUX_DIR([config])
+ AC_PREFIX_DEFAULT(/usr/local/pgsql)
+ AC_SUBST(configure_args, [$ac_configure_args])
+
diff --git a/libs/postgresql/patches/200-ranlib.patch b/libs/postgresql/patches/200-ranlib.patch
index 1b68b8378..5fc6d3db9 100644
--- a/libs/postgresql/patches/200-ranlib.patch
+++ b/libs/postgresql/patches/200-ranlib.patch
@@ -1,10 +1,10 @@
--- a/src/port/Makefile
+++ b/src/port/Makefile
-@@ -53,6 +53,7 @@ uninstall:
+@@ -52,6 +52,7 @@ uninstall:
libpgport.a: $(OBJS)
$(AR) $(AROPT) $@ $^
+ $(RANLIB) libpgport.a
# thread.o needs PTHREAD_CFLAGS (but thread_srv.o does not)
- thread.o: thread.c
+ thread.o: CFLAGS+=$(PTHREAD_CFLAGS)
diff --git a/libs/postgresql/patches/800-busybox-default-pager.patch b/libs/postgresql/patches/800-busybox-default-pager.patch
index 3cd253238..1be196991 100644
--- a/libs/postgresql/patches/800-busybox-default-pager.patch
+++ b/libs/postgresql/patches/800-busybox-default-pager.patch
@@ -1,6 +1,6 @@
--- a/src/bin/psql/print.h
+++ b/src/bin/psql/print.h
-@@ -171,10 +171,6 @@ extern void printQuery(const PGresult *r
+@@ -179,10 +179,6 @@ extern void printQuery(const PGresult *r
extern void setDecimalLocale(void);
extern const printTextFormat *get_line_style(const printTableOpt *opt);