aboutsummaryrefslogtreecommitdiff
path: root/libs/postgresql/patches
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2017-06-19 20:47:16 +0200
committerDaniel Golle <daniel@makrotopia.org>2017-06-19 20:49:40 +0200
commit2135991f51cddb8811d68e1fbe5d33daca1990f1 (patch)
tree2536a31b57270ca06721247f7d13fc7728d51a98 /libs/postgresql/patches
parentf64be26d2a08230a8f4bf9469c7ac748e1338167 (diff)
postgresql: fix build and improve packaging
* make sure contrib stuff gets built and installed * refresh patches and improve Makefile while at it Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'libs/postgresql/patches')
-rw-r--r--libs/postgresql/patches/001-configure_fixes.patch2
-rw-r--r--libs/postgresql/patches/050-build-contrib.patch11
-rw-r--r--libs/postgresql/patches/800-busybox-default-pager.patch4
-rw-r--r--libs/postgresql/patches/900-pg_ctl-setuid.patch20
4 files changed, 23 insertions, 14 deletions
diff --git a/libs/postgresql/patches/001-configure_fixes.patch b/libs/postgresql/patches/001-configure_fixes.patch
index bc0d2e15e..2edaba6a0 100644
--- a/libs/postgresql/patches/001-configure_fixes.patch
+++ b/libs/postgresql/patches/001-configure_fixes.patch
@@ -2,7 +2,7 @@
+++ b/configure.in
@@ -25,7 +25,7 @@ recommended. You can remove the check f
your responsibility whether the result works or not.])])
- AC_COPYRIGHT([Copyright (c) 1996-2015, PostgreSQL Global Development Group])
+ AC_COPYRIGHT([Copyright (c) 1996-2014, PostgreSQL Global Development Group])
AC_CONFIG_SRCDIR([src/backend/access/common/heaptuple.c])
-AC_CONFIG_AUX_DIR(config)
+AC_CONFIG_AUX_DIR([config])
diff --git a/libs/postgresql/patches/050-build-contrib.patch b/libs/postgresql/patches/050-build-contrib.patch
new file mode 100644
index 000000000..b127cf03a
--- /dev/null
+++ b/libs/postgresql/patches/050-build-contrib.patch
@@ -0,0 +1,11 @@
+--- a/GNUmakefile.in
++++ b/GNUmakefile.in
+@@ -8,7 +8,7 @@ subdir =
+ top_builddir = .
+ include $(top_builddir)/src/Makefile.global
+
+-$(call recurse,all install,src config)
++$(call recurse,all install,src config contrib)
+
+ all:
+ +@echo "All of PostgreSQL successfully made. Ready to install."
diff --git a/libs/postgresql/patches/800-busybox-default-pager.patch b/libs/postgresql/patches/800-busybox-default-pager.patch
index 0c6086783..1be196991 100644
--- a/libs/postgresql/patches/800-busybox-default-pager.patch
+++ b/libs/postgresql/patches/800-busybox-default-pager.patch
@@ -1,8 +1,8 @@
--- a/src/bin/psql/print.h
+++ b/src/bin/psql/print.h
-@@ -197,10 +197,6 @@ extern void setDecimalLocale(void);
+@@ -179,10 +179,6 @@ extern void printQuery(const PGresult *r
+ extern void setDecimalLocale(void);
extern const printTextFormat *get_line_style(const printTableOpt *opt);
- extern void refresh_utf8format(const printTableOpt *opt);
-#ifndef __CYGWIN__
-#define DEFAULT_PAGER "more"
diff --git a/libs/postgresql/patches/900-pg_ctl-setuid.patch b/libs/postgresql/patches/900-pg_ctl-setuid.patch
index f0bec3a13..b8d95e81c 100644
--- a/libs/postgresql/patches/900-pg_ctl-setuid.patch
+++ b/libs/postgresql/patches/900-pg_ctl-setuid.patch
@@ -1,8 +1,6 @@
-Index: postgresql-9.5.4/src/bin/pg_ctl/pg_ctl.c
-===================================================================
---- postgresql-9.5.4.orig/src/bin/pg_ctl/pg_ctl.c
-+++ postgresql-9.5.4/src/bin/pg_ctl/pg_ctl.c
-@@ -95,6 +95,7 @@ static char *event_source = NULL;
+--- a/src/bin/pg_ctl/pg_ctl.c
++++ b/src/bin/pg_ctl/pg_ctl.c
+@@ -94,6 +94,7 @@ static char *exec_path = NULL;
static char *register_servicename = "PostgreSQL"; /* FIXME: + version ID? */
static char *register_username = NULL;
static char *register_password = NULL;
@@ -10,8 +8,8 @@ Index: postgresql-9.5.4/src/bin/pg_ctl/pg_ctl.c
static char *argv0 = NULL;
static bool allow_core_files = false;
static time_t start_time;
-@@ -2114,6 +2115,9 @@ do_help(void)
- #endif
+@@ -2093,6 +2094,9 @@ do_help(void)
+ printf(_(" -D, --pgdata=DATADIR location of the database storage area\n"));
printf(_(" -s, --silent only print errors, no informational messages\n"));
printf(_(" -t, --timeout=SECS seconds to wait when using -w option\n"));
+#if !defined(WIN32) && !defined(__CYGWIN__)
@@ -20,7 +18,7 @@ Index: postgresql-9.5.4/src/bin/pg_ctl/pg_ctl.c
printf(_(" -V, --version output version information, then exit\n"));
printf(_(" -w wait until operation completes\n"));
printf(_(" -W do not wait until operation completes\n"));
-@@ -2310,6 +2314,7 @@ main(int argc, char **argv)
+@@ -2289,6 +2293,7 @@ main(int argc, char **argv)
{"pgdata", required_argument, NULL, 'D'},
{"silent", no_argument, NULL, 's'},
{"timeout", required_argument, NULL, 't'},
@@ -28,7 +26,7 @@ Index: postgresql-9.5.4/src/bin/pg_ctl/pg_ctl.c
{"core-files", no_argument, NULL, 'c'},
{NULL, 0, NULL, 0}
};
-@@ -2350,20 +2355,6 @@ main(int argc, char **argv)
+@@ -2329,20 +2334,6 @@ main(int argc, char **argv)
}
}
@@ -49,7 +47,7 @@ Index: postgresql-9.5.4/src/bin/pg_ctl/pg_ctl.c
env_wait = getenv("PGCTLTIMEOUT");
if (env_wait != NULL)
-@@ -2449,11 +2440,15 @@ main(int argc, char **argv)
+@@ -2416,11 +2407,15 @@ main(int argc, char **argv)
wait_seconds_arg = true;
break;
case 'U':
@@ -65,7 +63,7 @@ Index: postgresql-9.5.4/src/bin/pg_ctl/pg_ctl.c
break;
case 'w':
do_wait = true;
-@@ -2535,6 +2530,41 @@ main(int argc, char **argv)
+@@ -2502,6 +2497,41 @@ main(int argc, char **argv)
exit(1);
}