aboutsummaryrefslogtreecommitdiff
path: root/libs/poco/patches/200-strerror.patch
diff options
context:
space:
mode:
authorjmjulien <jean-michel.julien@trilliantinc.com>2016-02-23 14:47:04 -0500
committerjmjulien <jean-michel.julien@trilliantinc.com>2016-03-11 11:38:41 -0500
commit6123f54c951361efb23e9b1fe08d56bacb52220d (patch)
tree0d203b077a120580d339c4cb8430eb8a8bd66b78 /libs/poco/patches/200-strerror.patch
parent69f2c22384b157ab08e4b4666a200b59feaef70e (diff)
poco:add package for the Poco C++ library
POrtable COmponents is a Modern, powerful open source C++ class libraries for building network- and internet-based applications that run on desktop, server, mobile and embedded systems. Original Makefile --> https://dev.openwrt.org/browser/packages/libs/poco/Makefile add license add maintainer update URL to latest github stable version (1.7.0) change patch to the configure file add a patch to build with musl-libc Signed-off-by: Jean-Michel Julien <jean-michel.julien@trilliantinc.com>
Diffstat (limited to 'libs/poco/patches/200-strerror.patch')
-rw-r--r--libs/poco/patches/200-strerror.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/libs/poco/patches/200-strerror.patch b/libs/poco/patches/200-strerror.patch
new file mode 100644
index 000000000..54cce519e
--- /dev/null
+++ b/libs/poco/patches/200-strerror.patch
@@ -0,0 +1,11 @@
+--- a/Foundation/src/Error.cpp
++++ b/Foundation/src/Error.cpp
+@@ -66,7 +66,7 @@
+ without -D_GNU_SOURCE is needed, otherwise the GNU version is
+ preferred.
+ */
+-#if defined _GNU_SOURCE && !POCO_ANDROID
++#if (defined _GNU_SOURCE && (defined __GLIBC__ || defined __UCLIBC__)) && !POCO_ANDROID
+ char errmsg[256] = "";
+ return std::string(strerror_r(errorCode, errmsg, 256));
+ #elif (_XOPEN_SOURCE >= 600) || POCO_ANDROID