aboutsummaryrefslogtreecommitdiff
path: root/libs/pcre
diff options
context:
space:
mode:
authorThomas Heil <heil@terminal-consulting.de>2014-06-30 18:59:31 +0200
committerThomas Heil <heil@terminal-consulting.de>2014-06-30 18:59:31 +0200
commiteeab7d20fc4bbd70f7bfba5db9e6dd4ac9411140 (patch)
tree9e0a469948a1f87580a8473cfa5ac2210c6c5e8c /libs/pcre
parent1696bcef818fedd791e30c3c7c7c17b2a5aae7b6 (diff)
libpcre: import from packages, add myself as the maintainer
This adds the pcre, aka libpcre package from the old svn tree. Ive updated the package to the last version end checked that it builds with various plattforms. The patch 750-pcre_config_cross.patch is not longer necessary, so I removed him. The old package needs to be removed from the svn package tree. Signed-off-by: Thomas Heil <heil@terminal-consulting.de>
Diffstat (limited to 'libs/pcre')
-rw-r--r--libs/pcre/Makefile90
1 files changed, 90 insertions, 0 deletions
diff --git a/libs/pcre/Makefile b/libs/pcre/Makefile
new file mode 100644
index 000000000..e2c7d9c11
--- /dev/null
+++ b/libs/pcre/Makefile
@@ -0,0 +1,90 @@
+#
+# Copyright (C) 2006-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=pcre
+PKG_VERSION:=8.35
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/pcre
+PKG_MD5SUM:=6aacb23986adccd9b3bc626c00979958
+PKG_MAINTAINER:=Thomas Heil <heil@terminal-consulting.de>
+
+PKG_LICENSE:=BSD-3c
+PKG_LICENSE_FILES:=LICENCE
+
+PKG_FIXUP:=autoreconf
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libpcre/default
+ SECTION:=libs
+ CATEGORY:=Libraries
+ URL:=http://www.pcre.org/
+endef
+
+define Package/libpcre
+ $(call Package/libpcre/default)
+ TITLE:=A Perl Compatible Regular Expression library
+endef
+
+define Package/libpcrecpp
+ $(call Package/libpcre/default)
+ TITLE:=C++ wrapper for Perl Compatible Regular Expression library
+ DEPENDS:=+libpcre +libstdcpp
+endef
+
+
+TARGET_CFLAGS += $(FPIC)
+
+CONFIGURE_ARGS += \
+ --enable-utf8 \
+ --enable-unicode-properties \
+
+ifneq ($(CONFIG_PACKAGE_libpcrecpp),)
+ CONFIGURE_ARGS+= --enable-cpp
+else
+ CONFIGURE_ARGS+= --disable-cpp
+endif
+
+MAKE_FLAGS += \
+ CFLAGS="$(TARGET_CFLAGS)"
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/pcre-config $(1)/usr/bin/
+
+ $(INSTALL_DIR) $(2)/bin
+ $(LN) $(STAGING_DIR)/usr/bin/pcre-config $(2)/bin
+
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/pcre*.h $(1)/usr/include/
+
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpcre*.{a,so*} $(1)/usr/lib//
+
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libpcre*.pc $(1)/usr/lib/pkgconfig/
+
+endef
+
+define Package/libpcre/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpcre{,posix}.so.* $(1)/usr/lib/
+endef
+
+define Package/libpcrecpp/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpcrecpp.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libpcre))
+$(eval $(call BuildPackage,libpcrecpp))