aboutsummaryrefslogtreecommitdiff
path: root/libs/pcre
diff options
context:
space:
mode:
authorThomas Heil <heil@terminal-consulting.de>2017-09-03 15:03:56 +0200
committerThomas Heil <heil@terminal-consulting.de>2017-09-03 15:03:56 +0200
commit110b619b3891d49732c95361748218ce35a0e26c (patch)
treef52fb97672dc31ca96bd2042ce3281652c808d5e /libs/pcre
parent2c80296a6cfba912dae18ab83b01fe190888cc39 (diff)
pcre: Added fix for CVE-2017-11164 by adding stack recursion limit
Signed-off-by: Thomas Heil <heil@terminal-consulting.de>
Diffstat (limited to 'libs/pcre')
-rw-r--r--libs/pcre/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/libs/pcre/Makefile b/libs/pcre/Makefile
index 952deb6a5..ba4d571ce 100644
--- a/libs/pcre/Makefile
+++ b/libs/pcre/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=pcre
PKG_VERSION:=8.41
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/
@@ -53,6 +53,7 @@ CONFIGURE_ARGS += \
--enable-utf8 \
--enable-unicode-properties \
--enable-pcre16 \
+ --with-match-limit-recursion=16000 \
ifneq ($(CONFIG_PACKAGE_libpcrecpp),)
CONFIGURE_ARGS+= --enable-cpp