aboutsummaryrefslogtreecommitdiff
path: root/libs/pcre2
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-12-07 18:28:39 -0800
committerRosen Penev <rosenp@gmail.com>2020-12-07 20:18:35 -0800
commit5e814c7972feddfedd8c5ea4107a4a3f969b10e8 (patch)
treeae9dec372c59494eae64a0e4855cc4f445813b3f /libs/pcre2
parentea80600e3c390025b617aa8b25382c228f4c5b01 (diff)
pcre2: install pcre2-config to host path
Helps old packages that do not use pkgconfig. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/pcre2')
1 files changed, 4 insertions, 4 deletions
diff --git a/libs/pcre2/Makefile b/libs/pcre2/Makefile
index 28743ba19..d3172e662 100644
--- a/libs/pcre2/Makefile
+++ b/libs/pcre2/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=pcre2
PKG_VERSION:=10.35
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/pcre/$(PKG_NAME)/$(PKG_VERSION)
@@ -68,9 +68,9 @@ CMAKE_OPTIONS += \
define Build/InstallDev
$(call Build/InstallDev/cmake,$(1))
- $(SED) \
- 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
- $(1)/usr/bin/pcre2-config
+ $(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' $(1)/usr/bin/pcre2-config
+ $(INSTALL_DIR) $(2)/bin
+ $(LN) ../../usr/bin/pcre2-config $(2)/bin/pcre2-config
endef
define Package/libpcre2/install